summaryrefslogtreecommitdiff
path: root/meta-amd
diff options
context:
space:
mode:
authorKonstantin Aladyshev <aladyshev22@gmail.com>2021-04-19 11:28:05 +0300
committerKonstantin Aladyshev <aladyshev22@gmail.com>2021-04-21 16:57:17 +0300
commit7ba39779c5319a02a91680f2281f5179f4d7551c (patch)
tree6b66098c80365785c83000ae6ffa191c076f68d7 /meta-amd
parent62ee4a2368fe103dff793329d68c958e95b05c31 (diff)
downloadopenbmc-7ba39779c5319a02a91680f2281f5179f4d7551c.tar.xz
meta-amd: Add entity-manager configurations for AMD EthanolX
Add entity-manager baseboard and chassis json configurations for AMD EthanolX. bb append entity-manager recipe to include above files. Sigened-off-by: Supreeth Venkatesh <supreeth.venkatesh@amd.com> Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com> Change-Id: I766be9587149fe54034ff8e01aa1013797f873a9
Diffstat (limited to 'meta-amd')
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-baseboard.json280
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-chassis.json77
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend10
3 files changed, 367 insertions, 0 deletions
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-baseboard.json b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-baseboard.json
new file mode 100644
index 000000000..0ce9f8096
--- /dev/null
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-baseboard.json
@@ -0,0 +1,280 @@
+{
+ "Exposes": [
+ {
+ "Name": "P0 Fan connector",
+ "Status": "disabled",
+ "Type": "FanConnector"
+ },
+ {
+ "Name": "P1 Fan connector",
+ "Status": "disabled",
+ "Type": "FanConnector"
+ },
+ {
+ "Address": "0x48",
+ "Bus": 7,
+ "Name": "BMC",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x49",
+ "Bus": 7,
+ "Name": "DIMM_P0_ABCD_P1_EFGH",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4A",
+ "Bus": 7,
+ "Name": "DIMM_P1_EFGH",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4B",
+ "Bus": 7,
+ "Name": "PCIe_Slots",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4C",
+ "Bus": 7,
+ "Name": "DIMM_P0_EFGH_P1_ABCD",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4D",
+ "Bus": 7,
+ "Name": "DIMM_P1_ABCD",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4E",
+ "Bus": 7,
+ "Name": "DIMM_P0_EFGH",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4F",
+ "Bus": 7,
+ "Name": "DIMM_P0_ABCD",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ }
+ ],
+ "Name": "AMD EthanolX Baseboard",
+ "Probe": "TRUE",
+ "Type": "Board",
+ "ProductId": "1",
+ "xyz.openbmc_project.Inventory.Decorator.Asset": {
+ "Manufacturer": "AMD",
+ "Model": "EthanolX",
+ "PartNumber": "109-H43111-00A_02",
+ "SerialNumber": "EX782B"
+ }
+}
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-chassis.json b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-chassis.json
new file mode 100644
index 000000000..ff4cbdc54
--- /dev/null
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-chassis.json
@@ -0,0 +1,77 @@
+{
+ "Exposes": [
+ {
+ "Index": 0,
+ "BindConnector": "P0 Fan connector",
+ "MaxReading": 6000,
+ "Name": "P0_Fan",
+ "Type": "AspeedFan",
+ "Pwm": 1,
+ "Tachs": [1],
+ "Thresholds": [
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 10
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 10000
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 8000
+ }
+ ]
+ },
+ {
+ "Index": 1,
+ "BindConnector": "P1 Fan connector",
+ "MaxReading": 6000,
+ "Name": "P1_Fan",
+ "Type": "AspeedFan",
+ "Pwm": 2,
+ "Tachs": [2],
+ "Thresholds": [
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 10
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 10000
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 8000
+ }
+ ]
+ }
+ ],
+ "Name": "AMD EthanolX Chassis",
+ "Probe": "FOUND('AMD EthanolX Baseboard')",
+ "Type": "Chassis"
+}
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
new file mode 100644
index 000000000..5a287694d
--- /dev/null
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+SRC_URI_append = " file://ethanolx-baseboard.json \
+ file://ethanolx-chassis.json"
+
+do_install_append() {
+ rm -f ${D}/usr/share/entity-manager/configurations/*.json
+ install -d ${D}/usr/share/entity-manager/configurations
+ install -m 0444 ${WORKDIR}/ethanolx-baseboard.json ${D}/usr/share/entity-manager/configurations
+ install -m 0444 ${WORKDIR}/ethanolx-chassis.json ${D}/usr/share/entity-manager/configurations
+}