summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common/recipes-phosphor/inventory
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-12-30 07:35:08 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-12-30 08:13:21 +0300
commit51a992da77acde9850afc13e93685640319d86e3 (patch)
treeb9eea370ae6974a6f625fb54a26133a0b589b374 /meta-ampere/meta-common/recipes-phosphor/inventory
parent4a0948d0184e35770ca24cd591e9a29fd5ff44a6 (diff)
downloadopenbmc-51a992da77acde9850afc13e93685640319d86e3.tar.xz
meta-ampere: redfish: remove Chassis chassis instance
The chassis instance when implementing sensor monitor using dbus-sensor/entity-manager is /redfish/v1/Chassis/<name> where <name> is defined from entity-manager configuration. This commit removes /redfish/v1/Chassis/chassis which is redundant and make incorrect link from other schema like ComputerSystem and BMC Manager. Tested: 1. Check no /redfish/v1/Chassis/chassis available. 2. Check all sensors are available in /redfish/v1/Chassis/Mt_Jade. Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I334a94bb65c3caa49d0bcb6ab03a42f7999728d5
Diffstat (limited to 'meta-ampere/meta-common/recipes-phosphor/inventory')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb17
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml16
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
new file mode 100644
index 000000000..1b5a119b1
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+S = "${WORKDIR}"
+
+SRC_URI = "file://inventory-cleanup.yaml"
+
+do_install() {
+ install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
+}
+
+FILES:${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"
diff --git a/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml
new file mode 100644
index 000000000..23f54e331
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml
@@ -0,0 +1,16 @@
+description: >
+ Ampere inventory fixups
+
+events:
+ - name: Add Chassis interface
+ description: >
+ Add the chassis interface on the chassis inventory path
+ type: startup
+ actions:
+ - name: createObjects
+ objs:
+ /system/chassis:
+ xyz.openbmc_project.Inventory.Item.Chassis:
+ Type:
+ value: "xyz.openbmc_project.Inventory.Item.Chassis.ChassisType.RackMount"
+ type: string