summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-11-05 18:45:06 +0300
committerGitHub <noreply@github.com>2021-11-05 18:45:06 +0300
commit4dac5fcd49b5e2de1074f1363775ec0f19041072 (patch)
tree5aadf91080299b1583caed86a31da368dfcda2da /meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb
parent0c9e31989c615598b5d042ffab385606660c93c0 (diff)
parent61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b (diff)
downloadopenbmc-4dac5fcd49b5e2de1074f1363775ec0f19041072.tar.xz
Merge pull request #74 from Intel-BMC/update2021-0.771-0.77
Update
Diffstat (limited to 'meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb b/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb
new file mode 100644
index 000000000..e0a6819b6
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Ampere OEM IPMI commands"
+DESCRIPTION = "Ampere OEM IPMI commands"
+
+LICENSE = "Apache-2.0"
+S = "${WORKDIR}"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod"
+
+inherit cmake obmc-phosphor-ipmiprovider-symlink
+
+EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
+
+LIBRARY_NAMES = "libzampoemcmds.so"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/ampere-ipmi-oem.git"
+SRCREV = "1463f7013a17699081c1fbf506ee8d57827d1088"
+
+HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+
+FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
+
+do_install:append(){
+ install -d ${D}${includedir}/ampere-ipmi-oem
+ install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/ampere-ipmi-oem
+}