summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-12-14 16:06:22 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-12-16 11:36:57 +0300
commitcd92b83260b660c8df5a7c047885ef1c79b8fe99 (patch)
treeffb15fb5fcac95130321853d7ab376c1e24077bb /meta-ampere/meta-common
parentc2d043808ea75c3ca1a9e476bd5f64636ed53a88 (diff)
downloadopenbmc-cd92b83260b660c8df5a7c047885ef1c79b8fe99.tar.xz
meta-ampere: mtjade: fru: use dynamic sensors
Change to use dynamic sensors for FRU support to take advantage of IPMI fru read/write commands. Tested: 1. Check FRU reading $ ipmitool fru print 2. Write fru.bin into FRU EEPROM Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Signed-off-by: Thang Tran <thuutran@amperecomputing.com> Change-Id: I0d0b52ae7b0fd301a14d0d2894268637d867a5b8
Diffstat (limited to 'meta-ampere/meta-common')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
new file mode 100644
index 000000000..75177dce1
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+inherit obmc-phosphor-systemd
+
+HOSTIPMI_PROVIDER_LIBRARY:remove = "libstrgfnhandler.so"
+
+do_install:append () {
+ rm -rf ${D}${libdir}/ipmid-providers
+}