summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common
diff options
context:
space:
mode:
authorHieu Huynh <hieuh@os.amperecomputing.com>2021-09-24 05:44:10 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-09-25 10:26:34 +0300
commitf3911cd3ea5f09fceeeb6dc1253db17775729193 (patch)
tree10f9165fe249de2fb69fed7e1ea7ff0cdf863eac /meta-ampere/meta-common
parent208c2ae8c42071a5a0cbbe28972503381693e84c (diff)
downloadopenbmc-f3911cd3ea5f09fceeeb6dc1253db17775729193.tar.xz
meta-ampere: enable ampere-ipmi-oem repo
Adds the ampere-ipmi-oem.bb file to support ampere-ipmi-oem features. Signed-off-by: Hieu Huynh <hieuh@os.amperecomputing.com> Change-Id: I869a3e73573dd43103b52640ef3ac2d1912280dc
Diffstat (limited to 'meta-ampere/meta-common')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb b/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb
new file mode 100644
index 000000000..e0a6819b6
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Ampere OEM IPMI commands"
+DESCRIPTION = "Ampere OEM IPMI commands"
+
+LICENSE = "Apache-2.0"
+S = "${WORKDIR}"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod"
+
+inherit cmake obmc-phosphor-ipmiprovider-symlink
+
+EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
+
+LIBRARY_NAMES = "libzampoemcmds.so"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/ampere-ipmi-oem.git"
+SRCREV = "1463f7013a17699081c1fbf506ee8d57827d1088"
+
+HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+
+FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
+
+do_install:append(){
+ install -d ${D}${includedir}/ampere-ipmi-oem
+ install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/ampere-ipmi-oem
+}