summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-ampere
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-09-02 00:17:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-09-02 16:19:25 +0300
commite83c22094b7e4970c96bcee273ab08d05bbc0a30 (patch)
tree80cb87a34afb07b7d375b534bb5df68468c2b5a6 /meta-ampere/meta-jade/recipes-ampere
parentd97cf9b9ef84cdad2f357164e36b76619e7dc379 (diff)
downloadopenbmc-e83c22094b7e4970c96bcee273ab08d05bbc0a30.tar.xz
meta-phosphor: change systemd.bbclass to match upstream override syntax
Upstream bbclasses changed to typically use the `:${PN}` override syntax, including the SYSTEMD_ variables. Change our systemd.bbclass to do the same for consistency and perform a tree-wide variable replacement. Spot checked by building bletchley and witherspoon and checking some of the SYSTEMD_LINK directives on installed packages under qemu. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
Diffstat (limited to 'meta-ampere/meta-jade/recipes-ampere')
-rw-r--r--meta-ampere/meta-jade/recipes-ampere/platform/mtjade-gpio-config.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-ampere/meta-jade/recipes-ampere/platform/mtjade-gpio-config.bb b/meta-ampere/meta-jade/recipes-ampere/platform/mtjade-gpio-config.bb
index cc79f5b1a..8886fec6c 100644
--- a/meta-ampere/meta-jade/recipes-ampere/platform/mtjade-gpio-config.bb
+++ b/meta-ampere/meta-jade/recipes-ampere/platform/mtjade-gpio-config.bb
@@ -28,14 +28,14 @@ CHASSIS_POWERON_SVC = "ampere-gpio-poweron@.service"
CHASSIS_POWERON_INSTMPL = "ampere-gpio-poweron@{0}.service"
CHASSIS_POWERON_TGTFMT = "obmc-chassis-poweron@{0}.target"
CHASSIS_POWERON_FMT = "../${CHASSIS_POWERON_SVC}:${CHASSIS_POWERON_TGTFMT}.requires/${CHASSIS_POWERON_INSTMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'CHASSIS_POWERON_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'CHASSIS_POWERON_FMT', 'OBMC_CHASSIS_INSTANCES')}"
# chassis power off
CHASSIS_POWEROFF_SVC = "ampere-gpio-poweroff@.service"
CHASSIS_POWEROFF_INSTMPL = "ampere-gpio-poweroff@{0}.service"
CHASSIS_POWEROFF_TGTFMT = "obmc-chassis-poweroff@{0}.target"
CHASSIS_POWEROFF_FMT = "../${CHASSIS_POWEROFF_SVC}:${CHASSIS_POWEROFF_TGTFMT}.requires/${CHASSIS_POWEROFF_INSTMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'CHASSIS_POWEROFF_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'CHASSIS_POWEROFF_FMT', 'OBMC_CHASSIS_INSTANCES')}"
do_install() {
install -d ${D}/usr/sbin