summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-02-05 17:38:50 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-02-09 01:44:09 +0300
commit38e84136d5ea0f52126d7c2a1c629e0eb3653039 (patch)
tree6e1d6c72a855c21fa7571891dfed0a07114557c7 /meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
parent111b57c119533e0fc87cb654daecaa36b233b9e4 (diff)
downloadopenbmc-38e84136d5ea0f52126d7c2a1c629e0eb3653039.tar.xz
meta-ampere: mtjade: support FRU inventory
Support to parse the Mt.Jade FRU device, map FRU data with inventory information and report FRU content via IPMI. Tested: 1. Run IPMI fru print command: root@mtjade:~# ipmitool fru print FRU Device Description : Builtin FRU Device (ID 0) Chassis Type : Rack Mount Chassis Chassis Serial : A1A1-A000-0000000000123 Board Mfg Date : Fri Feb 5 00:00:00 2021 UTC Board Mfg : WIWYNN Board Product : Mt.Jade Motherboard Board Serial : B8103010002500900019J0LB Board Part Number : B81.03010.0026 Product Manufacturer : WIWYNN Product Name : Mt.Jade Server System Product Part Number : B81.03001.0009 Product Version : EVT2 Product Serial : B810300100050130002DN0SD 2. Check FRU inventory reoirt from REST /xyz/openbmc_project/inventory/system/chassis/motherboard Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I231d5766b2f89a535d850eb437d63a9db84fb846
Diffstat (limited to 'meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
new file mode 100644
index 000000000..be3e7fe5e
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -0,0 +1,26 @@
+inherit obmc-phosphor-systemd
+
+DEPENDS_append_mtjade = " mtjade-yaml-config"
+
+EXTRA_OECONF_mtjade = " \
+ YAML_GEN=${STAGING_DIR_HOST}${datadir}/mtjade-yaml-config/ipmi-fru-read.yaml \
+ PROP_YAML=${STAGING_DIR_HOST}${datadir}/mtjade-yaml-config/ipmi-extra-properties.yaml \
+ "
+FILESEXTRAPATHS_prepend_mtjade := "${THISDIR}/${PN}:"
+
+EEPROM_NAMES = "motherboard"
+
+EEPROMFMT = "system/chassis/{0}"
+EEPROM_ESCAPEDFMT = "system-chassis-{0}"
+EEPROMS = "${@compose_list(d, 'EEPROMFMT', 'EEPROM_NAMES')}"
+EEPROMS_ESCAPED = "${@compose_list(d, 'EEPROM_ESCAPEDFMT', 'EEPROM_NAMES')}"
+
+ENVFMT = "obmc/eeproms/{0}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_mtjade := "${@compose_list(d, 'ENVFMT', 'EEPROMS')}"
+
+TMPL = "obmc-read-eeprom@.service"
+TGT = "multi-user.target"
+INSTFMT = "obmc-read-eeprom@{0}.service"
+FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}"
+
+SYSTEMD_LINK_${PN}_append_mtjade := "${@compose_list(d, 'FMT', 'EEPROMS_ESCAPED')}"