summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-07-26 13:48:39 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-07-27 05:44:13 +0300
commit4621c74749b272720c757cc2585d2ff3ba842b3c (patch)
tree771a5fa94bc90bd3566607496b9dca203ce053ca /meta-ampere/meta-jade
parent905ef1dba3f7df79d35df0071f264f384eaedfc8 (diff)
downloadopenbmc-4621c74749b272720c757cc2585d2ff3ba842b3c.tar.xz
meta-ampere: mtjade: enable IPMI on eth1
NCSI was enabled in Mt.Jade device tree. This makes the RGMII port is now eth1. However, just eth0 is enabled for IPMI OOB so running IPMI OOB command is fail with RGMII's IP address. This commit sets eth1 as default Ethernet port for IPMI OOB command and set eth0 as alternative IPMI OOB port. Tested: 1. Run IPMI commands from client with RGMII's IP address $ ipmitool -U root -P 0penBmc -C 17 -I lanplus -H 10.38.64.72 power status Chassis Power is on Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: Iba65221b8cab99486d1f35026e0cf593cce4a8c9
Diffstat (limited to 'meta-ampere/meta-jade')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend b/meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
new file mode 100644
index 000000000..33802713d
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
@@ -0,0 +1,7 @@
+DEFAULT_RMCPP_IFACE = "eth1"
+
+ALT_RMCPP_IFACE = "eth0"
+SYSTEMD_SERVICE_${PN} += " \
+ ${PN}@${ALT_RMCPP_IFACE}.service \
+ ${PN}@${ALT_RMCPP_IFACE}.socket \
+ "