summaryrefslogtreecommitdiff
path: root/meta-ampere
diff options
context:
space:
mode:
authorTung Nguyen <tungnguyen@os.amperecomputing.com>2020-12-15 10:15:44 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-01-30 18:57:15 +0300
commit51b9ac11f580ea23c7b76e09577d206e882aa028 (patch)
tree9a9e1f4c0adb4b7db50345285bf92add800230b7 /meta-ampere
parent9340787ec4c07464fb26cfb78f64586af5eff2b0 (diff)
downloadopenbmc-51b9ac11f580ea23c7b76e09577d206e882aa028.tar.xz
meta-ampere:meta-jade Add skeleton configuation
Add the Mt.Jade skeleton configuration to support the basic power control Tested: 1. Compile OpenBMC image and boot successfully on Mt.Jade 2. Check basic gpio get/set and the power control action successfully Signed-off-by: Tung Nguyen <tungnguyen@os.amperecomputing.com> Change-Id: Ifc4f5746c3fb7e8d5e30a12cf29dd3f02e5de953
Diffstat (limited to 'meta-ampere')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json54
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend1
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-ampere/meta-jade/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..dd218c0c9
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,54 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "PGOOD",
+ "power_up_outs": [
+ {"name": "BMC_SYS_PSON_L", "polarity": false},
+ {"name": "BMC_READY", "polarity": true}
+ ],
+ "reset_outs": [
+ {"name": "BMC_S0_SYSRESET_L", "polarity": false},
+ {"name": "BMC_S1_SYSRESET_L", "polarity": false}
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "PGOOD",
+ "pin": "F4",
+ "direction": "in"
+ },
+ {
+ "name": "BMC_SYS_PSON_L",
+ "pin": "F2",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_S0_SYSRESET_L",
+ "pin": "L3",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_S1_SYSRESET_L",
+ "pin": "L4",
+ "direction": "out"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "B4",
+ "direction": "both"
+ },
+ {
+ "name": "RESET_BUTTON",
+ "pin": "R5",
+ "direction": "both"
+ },
+ {
+ "name": "BMC_READY",
+ "pin": "AC5",
+ "direction": "out"
+ }
+ ]
+}
diff --git a/meta-ampere/meta-jade/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-ampere/meta-jade/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
new file mode 100644
index 000000000..83a929746
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_append_mtjade := "${THISDIR}/${PN}:"