summaryrefslogtreecommitdiff
path: root/meta-ampere
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-26 07:47:17 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-26 08:46:01 +0300
commit6b2472a0b397c403f08a70392f5891051b608221 (patch)
tree960483f25beebb916ace99e04d7d7d6354b1bb84 /meta-ampere
parent1e35dc86ae5f12ef7792b60048112533667f9746 (diff)
downloadopenbmc-6b2472a0b397c403f08a70392f5891051b608221.tar.xz
meta-ampere: mtjade: configure SOL parameters
Since 29086950, phosphor-net-ipmid has updated the SOL parameters by obtaining the attribute values of the xyz.openbmc_project.Ipmi.SOL interface. It is necessary to enable SOL by default on Mt.Jade with correct parameters. Tested: 1. ipmitool -I lanplus -H x -U x -P x -C 17 raw sol info 2. ipmitool -I lanplus -H x -U x -P x -C 17 sol activate ipmitool -I lanplus -H x -U x -P x -C 17 sol deactivate Use the above commands to successfully activate and deactivate SOL 3. Activate IPMI SOL and boot Host to Linux 5 times without disconnected. Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I8e4d0e06eaa9c8995cde27f17f0d0d274b553f0d
Diffstat (limited to 'meta-ampere')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/settings/phosphor-settings-manager/mtjade_settings.override.yml31
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend2
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/settings/phosphor-settings-manager/mtjade_settings.override.yml b/meta-ampere/meta-jade/recipes-phosphor/settings/phosphor-settings-manager/mtjade_settings.override.yml
new file mode 100644
index 000000000..757371647
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/settings/phosphor-settings-manager/mtjade_settings.override.yml
@@ -0,0 +1,31 @@
+/xyz/openbmc_project/ipmi/sol/eth0:
+ - Interface: xyz.openbmc_project.Ipmi.SOL
+ Properties:
+ Enable:
+ Default: 'true'
+ Privilege:
+ Default: 4
+ Progress:
+ Default: 0
+ RetryCount:
+ Default: 7
+ RetryIntervalMS:
+ Default: 100
+ Threshold:
+ Default: 1
+
+/xyz/openbmc_project/ipmi/sol/eth1:
+ - Interface: xyz.openbmc_project.Ipmi.SOL
+ Properties:
+ Enable:
+ Default: 'true'
+ Privilege:
+ Default: 4
+ Progress:
+ Default: 0
+ RetryCount:
+ Default: 7
+ RetryIntervalMS:
+ Default: 100
+ Threshold:
+ Default: 1
diff --git a/meta-ampere/meta-jade/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend b/meta-ampere/meta-jade/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
new file mode 100644
index 000000000..d64eaec4e
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI:append:mtjade = " file://mtjade_settings.override.yml"