summaryrefslogtreecommitdiff
path: root/meta-aspeed/recipes-bsp
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2020-03-20 04:47:07 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-22 19:55:46 +0300
commit52db5ae2099ba766ec53a034c38e8b1fea7f07c7 (patch)
treeb3cb7854a32b33be12eabf4e53ed1bf4649f8272 /meta-aspeed/recipes-bsp
parente06d73a863700126e8dc2cabcf1480b979767319 (diff)
downloadopenbmc-52db5ae2099ba766ec53a034c38e8b1fea7f07c7.tar.xz
u-boot-aspeed: Fix fw_env.config for ast2600
The configuration was not set at all, leaving us with the default configuration file from u-boot. This sets it to the u-boot environment partition, /dev/mtd2. (From meta-aspeed rev: fc48e308dd25b99535a5412cbbdf1fcd66238a9b) Change-Id: Ied346a6c15f0068b8ab54cec02bc89bf9e553127 Signed-off-by: Joel Stanley <joel@jms.id.au> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-aspeed/recipes-bsp')
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_nor.config2
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb4
2 files changed, 5 insertions, 1 deletions
diff --git a/meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_nor.config b/meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_nor.config
new file mode 100644
index 000000000..ccd037ee6
--- /dev/null
+++ b/meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_nor.config
@@ -0,0 +1,2 @@
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+/dev/mtd/u-boot-env 0x0000 0x10000 0x1000
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 59fdbdeab..821457901 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -5,6 +5,8 @@ DEPENDS += "mtd-utils"
PROVIDES += "u-boot-fw-utils"
+SRC_URI += "file://fw_env_ast2600_nor.config"
+
INSANE_SKIP_${PN} = "already-stripped"
EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
@@ -21,7 +23,7 @@ do_install () {
install -d ${D}${sysconfdir}
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 644 ${WORKDIR}/fw_env_ast2600_nor.config ${D}${sysconfdir}/fw_env.config
}
do_install_class-cross () {