summaryrefslogtreecommitdiff
path: root/meta-aspeed/recipes-bsp
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-04-30 23:26:24 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-05 03:55:47 +0300
commit83ecb75644b3d677c274188f9ac0b2374d6f6925 (patch)
tree26dbbdb4cf1a11ecbd488498820eacc2639936b8 /meta-aspeed/recipes-bsp
parent72d8dfeda3ed2313c30cab8d407460d7606526d8 (diff)
downloadopenbmc-83ecb75644b3d677c274188f9ac0b2374d6f6925.tar.xz
dunfell: utilize u-boot-aspeed.inc in sdk
The u-boot.inc from upstream has been moved into this repository as its upstream version is no longer compatible with openbmc/u-boot. See commit 9052e5b for more details. Some notes on attempting to get upstream to work. Got to issue 3 and decided that instead of trying to cherry-pick in specific fixes from upstream, we're going to need a full rebase. Until this is possible, I think our best option is to just use the .inc from the working version of poky which is what u-boot-aspeed.inc is. 1) Build directory (B) def moved to common .inc Define BUILD directory in u-boot-common-aspeed-sdk_2019.04.inc recipes-bsp/u-boot/u-boot-common-aspeed-sdk_2019.04.inc +B = "${WORKDIR}/build" 2) Support in Makefile for new u-boot-initial-env file Pull in the following commit: https://github.com/u-boot/u-boot/commit/bdaa73a5b3923257add182b4ab8058dbfa33421b Available in my fork: https://github.com/geissonator/u-boot/tree/v2019.04-aspeed-openbmc-u-boot-initial-env-fix 3) CONFIG_DEFAULT_DEVICE_TREE needed | arm-openbmc-linux-gnueabi-objcopy --gap-fill=0xff -j .text -j .secure_text -j .secure_data -j .rodata -j .hash -j .data -j .got -j .got.plt -j .u_boot_list -j .rel.dyn -j .binman_sym_table -j .text_rest -j .dtb.init.rodata -j .efi_runtime -j .efi_runtime_rel -O binary u-boot u-boot-nodtb.bin | make -f /home/andrewg/Code/openbmc/build/tmp/work/witherspoon_tacoma-openbmc-linux-gnueabi/u-boot-aspeed-sdk/1_v2019.04+gitAUTOINC+58583dd97d-r0/git/scripts/Makefile.build obj=arch/arm/dts dtbs | test -e arch/arm/dts/unset.dtb || ( \ | echo >&2; \ | echo >&2 "Device Tree Source is not correctly specified."; \ | echo >&2 "Please define 'CONFIG_DEFAULT_DEVICE_TREE'"; \ | echo >&2 "or build with 'DEVICE_TREE=<device_tree>' argument"; \ | echo >&2; \ (From meta-aspeed rev: cd159fccefe991336e798da35ed5a2b0abf27e62) Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I1d28bd1125fe5acb1e644a751e44c65772892d0c Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-aspeed/recipes-bsp')
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
index 78c352f27..3ecd17ce6 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
@@ -2,7 +2,7 @@ require u-boot-common-aspeed-sdk_${PV}.inc
UBOOT_MAKE_TARGET ?= "DEVICE_TREE=${UBOOT_DEVICETREE}"
-require recipes-bsp/u-boot/u-boot.inc
+require u-boot-aspeed.inc
PROVIDES += "u-boot"
DEPENDS += "bc-native dtc-native"