summaryrefslogtreecommitdiff
path: root/meta-aspeed/recipes-bsp
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2020-07-07 21:31:51 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-17 23:22:04 +0300
commite477865c81b6f0eb9886c5368bbda73082d8bd9f (patch)
tree9c48f42102c42c6da9d14303d41b4d462df43dbd /meta-aspeed/recipes-bsp
parentd221e0389dc9bafd72e541090a9c401a25a84ce3 (diff)
downloadopenbmc-e477865c81b6f0eb9886c5368bbda73082d8bd9f.tar.xz
u-boot-aspeed: Add fw_env.config for eMMC
Create a fw_env.config for eMMC with a redundant environment based on the mmc distro feature. The environment is located in the first eMMC partition in the User Data area. (From meta-aspeed rev: 3aa2db46e8097aa0a9627684686ca56b5d6b9872) Change-Id: I6e768e308f03513c6cf394a0adc7110d17322d49 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-aspeed/recipes-bsp')
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_mmc.config3
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb7
2 files changed, 9 insertions, 1 deletions
diff --git a/meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_mmc.config b/meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_mmc.config
new file mode 100644
index 000000000..4c7937e30
--- /dev/null
+++ b/meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_mmc.config
@@ -0,0 +1,3 @@
+# Device name Device offset Env. size
+/dev/mmcblk0p1 0x00000 0x10000
+/dev/mmcblk0p1 0x10000 0x10000
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 821457901..cebbee6e6 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -6,6 +6,10 @@ DEPENDS += "mtd-utils"
PROVIDES += "u-boot-fw-utils"
SRC_URI += "file://fw_env_ast2600_nor.config"
+SRC_URI += "file://fw_env_ast2600_mmc.config"
+
+ENV_CONFIG_FILE = "fw_env_ast2600_nor.config"
+ENV_CONFIG_FILE_df-phosphor-mmc = "fw_env_ast2600_mmc.config"
INSANE_SKIP_${PN} = "already-stripped"
EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
@@ -23,7 +27,8 @@ do_install () {
install -d ${D}${sysconfdir}
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
- install -m 644 ${WORKDIR}/fw_env_ast2600_nor.config ${D}${sysconfdir}/fw_env.config
+
+ install -m 644 ${WORKDIR}/${ENV_CONFIG_FILE} ${D}${sysconfdir}/fw_env.config
}
do_install_class-cross () {