summaryrefslogtreecommitdiff
path: root/meta-aspeed
diff options
context:
space:
mode:
authorJamin Lin <jamin_lin@aspeedtech.com>2021-12-08 11:41:55 +0300
committerJamin Lin <jamin_lin@aspeedtech.com>2021-12-21 05:39:27 +0300
commit17fea4afc95d5c672cf066c571ac8a6070d54162 (patch)
treea9b4a96635fad2bc71cf6f6ec6f96692ca5531f7 /meta-aspeed
parent4df005e22665afe3c59dbbb66e59f17d245fb15e (diff)
downloadopenbmc-17fea4afc95d5c672cf066c571ac8a6070d54162.tar.xz
socsec: update socsec tool to v1.0.0
1. To fix python modules not found such as bitarray at do_compile task , adds "DEPEND" to install dependencies. 2. Create a socsec.inc to place the common settings. 3. Create a socsec_1.0.0.bb to build socsec tool v1.0.0. Signed-off-by: Jamin Lin <jamin_lin@aspeedtech.com> Change-Id: I27a9216419555b58e7484e85506fa229f0e230b7
Diffstat (limited to 'meta-aspeed')
-rw-r--r--meta-aspeed/recipes-aspeed/python/socsec.inc27
-rw-r--r--meta-aspeed/recipes-aspeed/python/socsec_1.0.0.bb4
-rw-r--r--meta-aspeed/recipes-aspeed/python/socsec_git.bb23
3 files changed, 31 insertions, 23 deletions
diff --git a/meta-aspeed/recipes-aspeed/python/socsec.inc b/meta-aspeed/recipes-aspeed/python/socsec.inc
new file mode 100644
index 000000000..30ba30897
--- /dev/null
+++ b/meta-aspeed/recipes-aspeed/python/socsec.inc
@@ -0,0 +1,27 @@
+SUMMARY = "Secure-boot utilities for ASPEED BMC SoCs"
+HOMEPAGE = "https://github.com/AspeedTech-BMC/socsec/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d50b901333b4eedfee074ebcd6a6d611"
+
+BRANCH ?= "master"
+SRC_URI = "git://github.com/AspeedTech-BMC/socsec.git;protocol=https;branch=${BRANCH}"
+
+S = "${WORKDIR}/git"
+
+inherit python3native setuptools3
+
+DEPENDS += "${PYTHON_PN}-bitarray-native"
+DEPENDS += "${PYTHON_PN}-ecdsa-native"
+DEPENDS += "${PYTHON_PN}-pycryptodome-native"
+
+RDEPENDS:${PN} += "${PYTHON_PN}-bitarray"
+RDEPENDS:${PN} += "${PYTHON_PN}-core"
+RDEPENDS:${PN} += "${PYTHON_PN}-hexdump"
+RDEPENDS:${PN} += "${PYTHON_PN}-jsonschema"
+RDEPENDS:${PN} += "${PYTHON_PN}-jstyleson"
+RDEPENDS:${PN} += "${PYTHON_PN}-pycryptodome"
+RDEPENDS:${PN} += "${PYTHON_PN}-ecdsa"
+
+BBCLASSEXTEND = "native nativesdk"
+
diff --git a/meta-aspeed/recipes-aspeed/python/socsec_1.0.0.bb b/meta-aspeed/recipes-aspeed/python/socsec_1.0.0.bb
new file mode 100644
index 000000000..a67c4c9dc
--- /dev/null
+++ b/meta-aspeed/recipes-aspeed/python/socsec_1.0.0.bb
@@ -0,0 +1,4 @@
+include socsec.inc
+
+PV = "1.0.0+git${SRCPV}"
+SRCREV = "2787a252988f4811097995ef9e807b1b433bde9f"
diff --git a/meta-aspeed/recipes-aspeed/python/socsec_git.bb b/meta-aspeed/recipes-aspeed/python/socsec_git.bb
deleted file mode 100644
index 6034b2982..000000000
--- a/meta-aspeed/recipes-aspeed/python/socsec_git.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "Secure-boot utilities for ASPEED BMC SoCs"
-HOMEPAGE = "https://github.com/AspeedTech-BMC/socsec/"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d50b901333b4eedfee074ebcd6a6d611"
-
-SRC_URI = "git://github.com/AspeedTech-BMC/socsec/;protocol=https;branch=master"
-
-PV = "0.2.1+git${SRCPV}"
-SRCREV = "51bd4504bffb5044264cfe4c63b8fe8d48a114a9"
-
-S = "${WORKDIR}/git"
-
-inherit python3native setuptools3
-
-RDEPENDS:${PN} += "python3-bitarray"
-RDEPENDS:${PN} += "python3-core"
-RDEPENDS:${PN} += "python3-ecdsa"
-RDEPENDS:${PN} += "python3-jsonschema"
-RDEPENDS:${PN} += "python3-jstyleson"
-RDEPENDS:${PN} += "python3-pycryptodome"
-
-BBCLASSEXTEND = "native nativesdk"