summaryrefslogtreecommitdiff
path: root/meta-aspeed
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
commit36caa12533da01d4319c5ffe7613711a0ec7dea7 (patch)
tree591c2077bb14cfd9d23893d32cca71fa7a01bc9c /meta-aspeed
parent12bef3e1bf292dec5ac15af9fb41e86f7bcfb0cb (diff)
parent3cec7f5a630c1ddcad058eb76e1f732a5fa20d59 (diff)
downloadopenbmc-36caa12533da01d4319c5ffe7613711a0ec7dea7.tar.xz
Merge tag '0.45' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-aspeed')
-rw-r--r--meta-aspeed/conf/machine/evb-ast2600.conf3
-rw-r--r--meta-aspeed/recipes-aspeed/python/socsec_git.bb23
-rw-r--r--meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb4
3 files changed, 28 insertions, 2 deletions
diff --git a/meta-aspeed/conf/machine/evb-ast2600.conf b/meta-aspeed/conf/machine/evb-ast2600.conf
index 9fb38e090..e011045d2 100644
--- a/meta-aspeed/conf/machine/evb-ast2600.conf
+++ b/meta-aspeed/conf/machine/evb-ast2600.conf
@@ -5,3 +5,6 @@ UBOOT_DEVICETREE = "ast2600a1-evb"
require conf/machine/include/ast2600.inc
SERIAL_CONSOLES = "115200;ttyS4"
+
+# AST2600 EVB has 64MB SPI flash
+FLASH_SIZE = "65536"
diff --git a/meta-aspeed/recipes-aspeed/python/socsec_git.bb b/meta-aspeed/recipes-aspeed/python/socsec_git.bb
new file mode 100644
index 000000000..3de811a51
--- /dev/null
+++ b/meta-aspeed/recipes-aspeed/python/socsec_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Secure-boot utilities for ASPEED BMC SoCs"
+HOMEPAGE = "https://github.com/AspeedTech-BMC/socsec/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d50b901333b4eedfee074ebcd6a6d611"
+
+SRC_URI = "git://github.com/AspeedTech-BMC/socsec/;protocol=https;branch=develop"
+
+PV = "1.7+git${SRCPV}"
+SRCREV = "54cdd3b26262e66d2020a04cba55bc8b02090f1a"
+
+S = "${WORKDIR}/git"
+
+inherit python3native setuptools3
+
+RDEPENDS_${PN} += "python3-bitarray"
+RDEPENDS_${PN} += "python3-core"
+RDEPENDS_${PN} += "python3-hexdump"
+RDEPENDS_${PN} += "python3-jsonschema"
+RDEPENDS_${PN} += "python3-jstyleson"
+RDEPENDS_${PN} += "python3-pycryptodome"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
index ed4a10f02..45f09d7a3 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
@@ -1,6 +1,6 @@
KBRANCH ?= "dev-5.10"
-LINUX_VERSION ?= "5.10.14"
+LINUX_VERSION ?= "5.10.23"
-SRCREV="56621ca6dcf8c20fc7bc72771df00cd3d59c153b"
+SRCREV="6687842ee68152c5cc7b7f8ac771b25eaece056a"
require linux-aspeed.inc