summaryrefslogtreecommitdiff
path: root/meta-aspeed
diff options
context:
space:
mode:
authorAndrei Kartashev <a.kartashev@yadro.com>2021-07-29 09:01:35 +0300
committerJoel Stanley <joel@jms.id.au>2021-08-23 10:28:19 +0300
commitb60b7b1333de884fa780ab12c3b55e18c1383472 (patch)
tree033522c3282f2cd798a22f3a914c6f869079c972 /meta-aspeed
parent7204de528f32b4ef23d33c1318e656293997c311 (diff)
downloadopenbmc-b60b7b1333de884fa780ab12c3b55e18c1383472.tar.xz
u-boot-aspeed: improve env handling
This fixes some build errors we faced due to add new ast2500-based platform. * Allow to redefine input env file. * Backport providing "u-boot-default-env" from u-boot.inc * PROVIDES += "u-boot-fw-utils" is not enough, add also RPROVIDES Last two changes allows to exclude from build modern libubootenv which somewhy doesn't work for us. Signed-off-by: Andrei Kartashev <a.kartashev@yadro.com> Change-Id: I33f152c572f6c0b4d8b608375b252290efacd1ea
Diffstat (limited to 'meta-aspeed')
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb3
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc4
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb1
3 files changed, 7 insertions, 1 deletions
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
index 45505b073..a142c1731 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
@@ -21,11 +21,12 @@ SOCSEC_SIGN_EXTRA_OPTS ?= "--stack_intersects_verification_region=false"
UBOOT_ENV_SIZE:df-phosphor-mmc = "0x10000"
UBOOT_ENV:df-phosphor-mmc = "u-boot-env"
UBOOT_ENV_SUFFIX:df-phosphor-mmc = "bin"
+UBOOT_ENV_TXT:df-phosphor-mmc = "u-boot-env-ast2600.txt"
do_compile:append() {
if [ -n "${UBOOT_ENV}" ]
then
# Generate redundant environment image
- ${B}/tools/mkenvimage -r -s ${UBOOT_ENV_SIZE} -o ${WORKDIR}/${UBOOT_ENV_BINARY} ${WORKDIR}/u-boot-env-ast2600.txt
+ ${B}/tools/mkenvimage -r -s ${UBOOT_ENV_SIZE} -o ${WORKDIR}/${UBOOT_ENV_BINARY} ${WORKDIR}/${UBOOT_ENV_TXT}
fi
}
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
index 19de5d2c6..3028a9e19 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
@@ -182,7 +182,11 @@ do_install () {
}
+PACKAGE_BEFORE_PN += "${PN}-env"
+
+RPROVIDES:${PN}-env += "u-boot-default-env"
FILES:${PN} = "/boot ${sysconfdir} ${datadir}"
+RDEPENDS:${PN} += "${PN}-env"
do_deploy () {
if [ -n "${UBOOT_CONFIG}" ]
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 13a4081b0..6c1470a5f 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -4,6 +4,7 @@ SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
DEPENDS += "mtd-utils"
PROVIDES += "u-boot-fw-utils"
+RPROVIDES:${PN} += "u-boot-fw-utils"
SRC_URI += "file://fw_env_ast2600_nor.config"
SRC_URI += "file://fw_env_ast2600_mmc.config"