summaryrefslogtreecommitdiff
path: root/meta-aspeed
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:13:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commitb9799be79de3f0a15a14be392ee90574433435ad (patch)
tree3c65475447a820e83c873a0371ac0717763b82c3 /meta-aspeed
parented2ee5d25d6f756fe721e16b39aabbd475d982d9 (diff)
downloadopenbmc-b9799be79de3f0a15a14be392ee90574433435ad.tar.xz
meta-aspeed: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I8135871ae0e3b360aff7d878f7cf04a2504f2dd0
Diffstat (limited to 'meta-aspeed')
-rw-r--r--meta-aspeed/classes/socsec-sign.bbclass2
-rw-r--r--meta-aspeed/conf/layer.conf4
-rw-r--r--meta-aspeed/conf/machine/include/aspeed.inc22
-rw-r--r--meta-aspeed/recipes-aspeed/python/socsec_git.bb12
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb10
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc2
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb2
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb12
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb12
-rw-r--r--meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb2
-rw-r--r--meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb2
11 files changed, 41 insertions, 41 deletions
diff --git a/meta-aspeed/classes/socsec-sign.bbclass b/meta-aspeed/classes/socsec-sign.bbclass
index 1b1576592..b5866e29e 100644
--- a/meta-aspeed/classes/socsec-sign.bbclass
+++ b/meta-aspeed/classes/socsec-sign.bbclass
@@ -59,7 +59,7 @@ sign_spl() {
}
-do_deploy_append() {
+do_deploy:append() {
if [ "${SOCSEC_SIGN_ENABLE}" = "1" -a -n "${SPL_BINARY}" ] ; then
sign_spl
fi
diff --git a/meta-aspeed/conf/layer.conf b/meta-aspeed/conf/layer.conf
index c0289753f..00302ddf5 100644
--- a/meta-aspeed/conf/layer.conf
+++ b/meta-aspeed/conf/layer.conf
@@ -6,5 +6,5 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "aspeed-layer"
BBFILE_PATTERN_aspeed-layer := "^${LAYERDIR}/"
-LAYERVERSION_aspeed-layer = "1"
-LAYERSERIES_COMPAT_aspeed-layer = "gatesgarth hardknott"
+LAYERVERSION:aspeed-layer = "1"
+LAYERSERIES_COMPAT_aspeed-layer = "gatesgarth hardknott honister"
diff --git a/meta-aspeed/conf/machine/include/aspeed.inc b/meta-aspeed/conf/machine/include/aspeed.inc
index fdc411981..628a73b1d 100644
--- a/meta-aspeed/conf/machine/include/aspeed.inc
+++ b/meta-aspeed/conf/machine/include/aspeed.inc
@@ -3,9 +3,9 @@ PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-aspeed"
PREFERRED_PROVIDER_u-boot ?= "u-boot-aspeed"
PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-fw-utils-aspeed"
-PREFERRED_PROVIDER_virtual/bootloader_aspeed-g6 ?= "u-boot-aspeed-sdk"
-PREFERRED_PROVIDER_u-boot_aspeed-g6 ?= "u-boot-aspeed-sdk"
-PREFERRED_PROVIDER_u-boot-fw-utils_aspeed-g6 ?= "u-boot-fw-utils-aspeed-sdk"
+PREFERRED_PROVIDER_virtual/bootloader:aspeed-g6 ?= "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot:aspeed-g6 ?= "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot-fw-utils:aspeed-g6 ?= "u-boot-fw-utils-aspeed-sdk"
# Build a FIT image and stuff core-image-minimal in it by default.
KERNEL_IMAGETYPE ?= "fitImage"
@@ -29,12 +29,12 @@ MACHINEOVERRIDES =. "aspeed:"
SERIAL_CONSOLES ?= "115200;ttyS4"
-DEFAULTTUNE_aspeed-g5 ?= "arm1176jzs"
-DEFAULTTUNE_aspeed-g6 ?= "armv7ahf-vfpv4d16"
+DEFAULTTUNE:aspeed-g5 ?= "arm1176jzs"
+DEFAULTTUNE:aspeed-g6 ?= "armv7ahf-vfpv4d16"
-UBOOT_ENTRYPOINT_aspeed-g4 ?= "0x40001000"
-UBOOT_ENTRYPOINT_aspeed-g5 ?= "0x80001000"
-UBOOT_ENTRYPOINT_aspeed-g6 ?= "0x80001000"
-UBOOT_LOADADDRESS_aspeed-g4 ?= "0x40001000"
-UBOOT_LOADADDRESS_aspeed-g5 ?= "0x80001000"
-UBOOT_LOADADDRESS_aspeed-g6 ?= "0x80001000"
+UBOOT_ENTRYPOINT:aspeed-g4 ?= "0x40001000"
+UBOOT_ENTRYPOINT:aspeed-g5 ?= "0x80001000"
+UBOOT_ENTRYPOINT:aspeed-g6 ?= "0x80001000"
+UBOOT_LOADADDRESS:aspeed-g4 ?= "0x40001000"
+UBOOT_LOADADDRESS:aspeed-g5 ?= "0x80001000"
+UBOOT_LOADADDRESS:aspeed-g6 ?= "0x80001000"
diff --git a/meta-aspeed/recipes-aspeed/python/socsec_git.bb b/meta-aspeed/recipes-aspeed/python/socsec_git.bb
index 3de811a51..07b966c1c 100644
--- a/meta-aspeed/recipes-aspeed/python/socsec_git.bb
+++ b/meta-aspeed/recipes-aspeed/python/socsec_git.bb
@@ -13,11 +13,11 @@ S = "${WORKDIR}/git"
inherit python3native setuptools3
-RDEPENDS_${PN} += "python3-bitarray"
-RDEPENDS_${PN} += "python3-core"
-RDEPENDS_${PN} += "python3-hexdump"
-RDEPENDS_${PN} += "python3-jsonschema"
-RDEPENDS_${PN} += "python3-jstyleson"
-RDEPENDS_${PN} += "python3-pycryptodome"
+RDEPENDS:${PN} += "python3-bitarray"
+RDEPENDS:${PN} += "python3-core"
+RDEPENDS:${PN} += "python3-hexdump"
+RDEPENDS:${PN} += "python3-jsonschema"
+RDEPENDS:${PN} += "python3-jstyleson"
+RDEPENDS:${PN} += "python3-pycryptodome"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
index 727c62d27..56468270a 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
@@ -8,17 +8,17 @@ inherit socsec-sign
PROVIDES += "u-boot"
DEPENDS += "bc-native dtc-native"
-SRC_URI_append_df-phosphor-mmc = " file://u-boot-env-ast2600.txt"
+SRC_URI:append:df-phosphor-mmc = " file://u-boot-env-ast2600.txt"
SRC_URI += " \
file://rsa_oem_dss_key.pem;sha256sum=64a379979200d39949d3e5b0038e3fdd5548600b2f7077a17e35422336075ad4 \
file://rsa_pub_oem_dss_key.pem;sha256sum=40132a694a10af2d1b094b1cb5adab4d6b4db2a35e02d848b2b6a85e60738264 \
"
-UBOOT_ENV_SIZE_df-phosphor-mmc = "0x10000"
-UBOOT_ENV_df-phosphor-mmc = "u-boot-env"
-UBOOT_ENV_SUFFIX_df-phosphor-mmc = "bin"
+UBOOT_ENV_SIZE:df-phosphor-mmc = "0x10000"
+UBOOT_ENV:df-phosphor-mmc = "u-boot-env"
+UBOOT_ENV_SUFFIX:df-phosphor-mmc = "bin"
-do_compile_append() {
+do_compile:append() {
if [ -n "${UBOOT_ENV}" ]
then
# Generate redundant environment image
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
index 0b9bc20d2..19de5d2c6 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
@@ -182,7 +182,7 @@ do_install () {
}
-FILES_${PN} = "/boot ${sysconfdir} ${datadir}"
+FILES:${PN} = "/boot ${sysconfdir} ${datadir}"
do_deploy () {
if [ -n "${UBOOT_CONFIG}" ]
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
index 8cebe5ab3..395f5ab57 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
@@ -6,4 +6,4 @@ DEPENDS += "dtc-native"
# FIXME this can/should be removed when we have rebased off our
# 2016 snapshot onto a more modern (circa late 2018) u-boot tree.
-BUILD_CFLAGS_remove = "-isystem${STAGING_INCDIR_NATIVE}"
+BUILD_CFLAGS:remove = "-isystem${STAGING_INCDIR_NATIVE}"
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index cebbee6e6..13a4081b0 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -9,11 +9,11 @@ SRC_URI += "file://fw_env_ast2600_nor.config"
SRC_URI += "file://fw_env_ast2600_mmc.config"
ENV_CONFIG_FILE = "fw_env_ast2600_nor.config"
-ENV_CONFIG_FILE_df-phosphor-mmc = "fw_env_ast2600_mmc.config"
+ENV_CONFIG_FILE:df-phosphor-mmc = "fw_env_ast2600_mmc.config"
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+INSANE_SKIP:${PN} = "already-stripped"
+EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE:class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config
@@ -31,13 +31,13 @@ do_install () {
install -m 644 ${WORKDIR}/${ENV_CONFIG_FILE} ${D}${sysconfdir}/fw_env.config
}
-do_install_class-cross () {
+do_install:class-cross () {
install -d ${D}${bindir_cross}
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
}
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
BBCLASSEXTEND = "cross"
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
index e9f724df2..0ec64ce8e 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
@@ -9,9 +9,9 @@ DEPENDS += "mtd-utils"
PROVIDES += "u-boot-fw-utils"
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+INSANE_SKIP:${PN} = "already-stripped"
+EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE:class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config
@@ -30,15 +30,15 @@ do_install () {
install -m 644 ${WORKDIR}/alt_fw_env.config ${D}${sysconfdir}/alt_fw_env.config
}
-do_install_class-cross () {
+do_install:class-cross () {
install -d ${D}${bindir_cross}
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
}
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
BBCLASSEXTEND = "cross"
-RDEPENDS_${PN} = "udev-aspeed-mtd-partitions"
+RDEPENDS:${PN} = "udev-aspeed-mtd-partitions"
diff --git a/meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb b/meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb
index 9e85308cd..ea52c2ff2 100644
--- a/meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb
+++ b/meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
S = "${WORKDIR}"
SRC_URI += "file://76-aspeed-mtd-partitions.rules"
-RDEPENDS_${PN} += "udev"
+RDEPENDS:${PN} += "udev"
do_install() {
install -d ${D}/${base_libdir}/udev/rules.d
diff --git a/meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb b/meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb
index c0ee6771e..188b0a434 100644
--- a/meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb
+++ b/meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
S = "${WORKDIR}"
SRC_URI += "file://61-aspeed-vuart.rules"
-RDEPENDS_${PN} += "udev"
+RDEPENDS:${PN} += "udev"
do_install() {
install -d ${D}/lib/udev/rules.d