summaryrefslogtreecommitdiff
path: root/meta-aspeed
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2021-11-01 10:05:52 +0300
committerJoel Stanley <joel@jms.id.au>2021-11-02 02:01:02 +0300
commitd09d34f0e41343395386579f44b3fb57666be3a9 (patch)
tree4a4318d070a19f1c38c24f5ac9a9d0944cb7de9d /meta-aspeed
parentca5ea7551cb86239e4e4b046dab40be8d591b651 (diff)
downloadopenbmc-d09d34f0e41343395386579f44b3fb57666be3a9.tar.xz
linux-aspeed: Move to Linux v5.15
This moves the OpenBMC kernel to a v5.15 base. There are 73 patches in the tree, not counting changes that were merged in v5.16 which have been backported. Andrew Jeffery (10): dt-bindings: hwmon: pmbus: Add Maxim MAX31785 documentation pmbus (max31785): Add support for devicetree configuration pmbus (core): Use driver callbacks in pmbus_get_fan_rate() pmbus (core): One-shot retries for failure to set page pmbus (max31785): Wrap all I2C accessors in one-shot failure handlers ARM: dts: aspeed: witherspoon: Update max31785 node ipmi: kcs_bmc: Add a "raw" character device interface ARM: dts: tacoma: Clean up KCS nodes leds: pca955x: Make the gpiochip always expose all pins leds: pca955x: Allow zero LEDs to be specified Brad Bishop (3): ipmi: aspeed-g6: Add compatible strings reset: simple: Add AST2600 compatibility string eeprom: at25: Split reads into chunks and cap write size Cédric Le Goater (19): mtd: spi-nor: aspeed: use command mode for reads mtd: spi-nor: aspeed: add support for SPI dual IO read mode mtd: spi-nor: aspeed: link controller with the ahb clock mtd: spi-nor: aspeed: optimize read mode mtd: spi-nor: aspeed: limit the maximum SPI frequency mtd: spi-nor: aspeed: introduce a aspeed_smc_default_read() helper mtd: spi-nor: aspeed: clarify 4BYTE address mode mask mtd: spi-nor: aspeed: use memcpy_fromio() to capture the optimization buffer mtd: spi-nor: aspeed: add support for the 4B opcodes mtd: spi-nor: Add support for w25q512jv mtd: spi-nor: aspeed: Introduce a field for the AHB physical address mtd: spi-nor: aspeed: Introduce segment operations mtd: spi-nor: aspeed: add initial support for ast2600 mtd: spi-nor: aspeed: Check for disabled segments on the AST2600 mtd: spi-nor: aspeed: Introduce training operations per platform mtd: spi-nor: aspeed: Introduce a HCLK mask for training mtd: spi-nor: aspeed: check upper freq limit when doing training mtd: spi-nor: aspeed: add support for AST2600 training /dev/mem: add a devmem kernel parameter to activate the device Eddie James (8): soc: aspeed: Add XDMA Engine Driver soc: aspeed: xdma: Add user interface soc: aspeed: xdma: Add reset ioctl dt-bindings: input: Add documentation for IBM Operation Panel input: misc: Add IBM Operation Panel driver ARM: dts: aspeed: tacoma: Remove CFAM reset GPIO spi: fsi: Print status on error spi: fsi: Fix contention in the FSI2SPI engine Fran Hsu (2): ARM: dts: nuvoton: npcm730: Add UDC device ARM: dts: nuvoton: gsj: Add non-mainline nodes George Hung (4): dt-binding: edac: add NPCM ECC documentation edac: npcm: Add Nuvoton NPCM7xx EDAC driver ARM: dts: nuvoton: gbs: split SPI flash partition ARM: dts: nuvoton: gbs: Change the name of the partitions Jae Hyun Yoo (1): clk: ast2600: enable BCLK for PCI/PCIe bus always Joel Stanley (4): net: ftgmac100: Ensure tx descriptor updates are visible ARM: dts: ast2600evb: Enable EHCI controller ARM: configs: aspeed: Add openbmc kernel options ipmi: bt-bmc: Use registers directly Tomer Maimon (21): dt-binding: bmc: Add NPCM7xx LPC BPC documentation misc: npcm7xx-lpc-bpc: add NPCM7xx BIOS post code driver dt-binding: bmc: add npcm7xx pci mailbox document misc: mbox: add npcm7xx pci mailbox driver dt-binding: net: document NPCM7xx EMC DT bindings net: npcm: add NPCM7xx Ethernet MAC controller ARM: dts: npcm7xx: Add out of tree nodes ARM: dts: olympus: Add non-mainline nodes ARM: dts: npcm750: Add fuse regmap support node ARM: dts: npcm7xx: Link fuse syscon to adc and wdt clk: npcm7xx: add read only flag to divider clocks iio: adc: Add calibration support to npcm ADC watchdog: npcm: Add DT restart priority and reset type support pinctrl: npcm7xx: Add HGPIO pin support to NPCM7xx pinctrl driver pinctrl: pinconf: add pin persist configuration pinctrl: npcm7xx: Add pin persist configuration support spi: npcm-pspi: Add full duplex support dt-binding: bmc: add NPCM7XX JTAG master documentation misc: Add NPCM7xx JTAG master driver watchdog: npcm: Modify get reset status function ARM: configs: add defconfig for Nuvoton NPCM7xx BMC William A. Kennington III (1): net: npcm: Support for fixed PHYs Change-Id: I8c26f71ba75e4f8d8b5697b81f8c73c0d77aae8e Signed-off-by: Joel Stanley <joel@jms.id.au>
Diffstat (limited to 'meta-aspeed')
-rw-r--r--meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
index 7348b5167..4d1a2a827 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
@@ -1,6 +1,6 @@
-KBRANCH ?= "dev-5.14"
-LINUX_VERSION ?= "5.14.15"
+KBRANCH ?= "dev-5.15"
+LINUX_VERSION ?= "5.15"
-SRCREV="ea24e10732a20cb0c48369b131c1969c3ef7fade"
+SRCREV="4c17788708de45082e1c7c07d0b781368e809038"
require linux-aspeed.inc