summaryrefslogtreecommitdiff
path: root/meta-aspeed
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
commitd73e39703a0260c8911cb439b579e1c2bada4b20 (patch)
tree4fa9f965ae954c587ab773ecaced6b8f8e18d359 /meta-aspeed
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-d73e39703a0260c8911cb439b579e1c2bada4b20.tar.xz
Merge tag '0.75' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-aspeed')
-rw-r--r--meta-aspeed/classes/socsec-sign.bbclass5
-rw-r--r--meta-aspeed/conf/layer.conf2
-rw-r--r--meta-aspeed/conf/machine/include/aspeed.inc22
-rw-r--r--meta-aspeed/conf/machine/include/ast2400.inc2
-rw-r--r--meta-aspeed/conf/machine/include/ast2500.inc2
-rw-r--r--meta-aspeed/conf/machine/include/ast2600.inc5
-rw-r--r--meta-aspeed/recipes-aspeed/python/socsec_git.bb18
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb20
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc6
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb2
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb13
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb12
-rw-r--r--meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb6
-rw-r--r--meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb6
-rw-r--r--meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb4
15 files changed, 71 insertions, 54 deletions
diff --git a/meta-aspeed/classes/socsec-sign.bbclass b/meta-aspeed/classes/socsec-sign.bbclass
index 1b1576592..0af88d9f5 100644
--- a/meta-aspeed/classes/socsec-sign.bbclass
+++ b/meta-aspeed/classes/socsec-sign.bbclass
@@ -23,7 +23,8 @@ sign_spl_helper() {
if [ "${SOC_FAMILY}" != "aspeed-g6" ] ; then
echo "Warning: SPL signing is only supported on AST2600 boards"
elif [ ! -e "${SOCSEC_SIGN_KEY}" ] ; then
- echo "Warning: Invalid socsec signing key - SPL verified boot won't be available"
+ echo "Error: Invalid socsec signing key: ${SOCSEC_SIGN_KEY}"
+ exit 1
else
rm -f ${SPL_BINARY}.staged
@@ -59,7 +60,7 @@ sign_spl() {
}
-do_deploy_append() {
+do_deploy:append() {
if [ "${SOCSEC_SIGN_ENABLE}" = "1" -a -n "${SPL_BINARY}" ] ; then
sign_spl
fi
diff --git a/meta-aspeed/conf/layer.conf b/meta-aspeed/conf/layer.conf
index c0289753f..9dd3b72aa 100644
--- a/meta-aspeed/conf/layer.conf
+++ b/meta-aspeed/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "aspeed-layer"
BBFILE_PATTERN_aspeed-layer := "^${LAYERDIR}/"
LAYERVERSION_aspeed-layer = "1"
-LAYERSERIES_COMPAT_aspeed-layer = "gatesgarth hardknott"
+LAYERSERIES_COMPAT_aspeed-layer = "hardknott honister"
diff --git a/meta-aspeed/conf/machine/include/aspeed.inc b/meta-aspeed/conf/machine/include/aspeed.inc
index fdc411981..628a73b1d 100644
--- a/meta-aspeed/conf/machine/include/aspeed.inc
+++ b/meta-aspeed/conf/machine/include/aspeed.inc
@@ -3,9 +3,9 @@ PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-aspeed"
PREFERRED_PROVIDER_u-boot ?= "u-boot-aspeed"
PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-fw-utils-aspeed"
-PREFERRED_PROVIDER_virtual/bootloader_aspeed-g6 ?= "u-boot-aspeed-sdk"
-PREFERRED_PROVIDER_u-boot_aspeed-g6 ?= "u-boot-aspeed-sdk"
-PREFERRED_PROVIDER_u-boot-fw-utils_aspeed-g6 ?= "u-boot-fw-utils-aspeed-sdk"
+PREFERRED_PROVIDER_virtual/bootloader:aspeed-g6 ?= "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot:aspeed-g6 ?= "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot-fw-utils:aspeed-g6 ?= "u-boot-fw-utils-aspeed-sdk"
# Build a FIT image and stuff core-image-minimal in it by default.
KERNEL_IMAGETYPE ?= "fitImage"
@@ -29,12 +29,12 @@ MACHINEOVERRIDES =. "aspeed:"
SERIAL_CONSOLES ?= "115200;ttyS4"
-DEFAULTTUNE_aspeed-g5 ?= "arm1176jzs"
-DEFAULTTUNE_aspeed-g6 ?= "armv7ahf-vfpv4d16"
+DEFAULTTUNE:aspeed-g5 ?= "arm1176jzs"
+DEFAULTTUNE:aspeed-g6 ?= "armv7ahf-vfpv4d16"
-UBOOT_ENTRYPOINT_aspeed-g4 ?= "0x40001000"
-UBOOT_ENTRYPOINT_aspeed-g5 ?= "0x80001000"
-UBOOT_ENTRYPOINT_aspeed-g6 ?= "0x80001000"
-UBOOT_LOADADDRESS_aspeed-g4 ?= "0x40001000"
-UBOOT_LOADADDRESS_aspeed-g5 ?= "0x80001000"
-UBOOT_LOADADDRESS_aspeed-g6 ?= "0x80001000"
+UBOOT_ENTRYPOINT:aspeed-g4 ?= "0x40001000"
+UBOOT_ENTRYPOINT:aspeed-g5 ?= "0x80001000"
+UBOOT_ENTRYPOINT:aspeed-g6 ?= "0x80001000"
+UBOOT_LOADADDRESS:aspeed-g4 ?= "0x40001000"
+UBOOT_LOADADDRESS:aspeed-g5 ?= "0x80001000"
+UBOOT_LOADADDRESS:aspeed-g6 ?= "0x80001000"
diff --git a/meta-aspeed/conf/machine/include/ast2400.inc b/meta-aspeed/conf/machine/include/ast2400.inc
index 6284a2b64..cc99db025 100644
--- a/meta-aspeed/conf/machine/include/ast2400.inc
+++ b/meta-aspeed/conf/machine/include/ast2400.inc
@@ -1,4 +1,4 @@
SOC_FAMILY = "aspeed-g4"
include conf/machine/include/soc-family.inc
require conf/machine/include/aspeed.inc
-require conf/machine/include/tune-arm926ejs.inc
+require conf/machine/include/arm/armv5/tune-arm926ejs.inc
diff --git a/meta-aspeed/conf/machine/include/ast2500.inc b/meta-aspeed/conf/machine/include/ast2500.inc
index 0724157a9..681ce640e 100644
--- a/meta-aspeed/conf/machine/include/ast2500.inc
+++ b/meta-aspeed/conf/machine/include/ast2500.inc
@@ -1,4 +1,4 @@
SOC_FAMILY = "aspeed-g5"
include conf/machine/include/soc-family.inc
require conf/machine/include/aspeed.inc
-require conf/machine/include/tune-arm1176jz-s.inc
+require conf/machine/include/arm/armv6/tune-arm1176jz-s.inc
diff --git a/meta-aspeed/conf/machine/include/ast2600.inc b/meta-aspeed/conf/machine/include/ast2600.inc
index fff5465d9..1e5e1f8fe 100644
--- a/meta-aspeed/conf/machine/include/ast2600.inc
+++ b/meta-aspeed/conf/machine/include/ast2600.inc
@@ -1,4 +1,9 @@
SOC_FAMILY = "aspeed-g6"
+
+# Enable SPL signing by default
+SOCSEC_SIGN_ENABLE ?= "1"
+SOCSEC_SIGN_SOC ?= "2600"
+
include conf/machine/include/soc-family.inc
require conf/machine/include/aspeed.inc
include conf/machine/include/arm/arch-armv7a.inc
diff --git a/meta-aspeed/recipes-aspeed/python/socsec_git.bb b/meta-aspeed/recipes-aspeed/python/socsec_git.bb
index 3de811a51..6034b2982 100644
--- a/meta-aspeed/recipes-aspeed/python/socsec_git.bb
+++ b/meta-aspeed/recipes-aspeed/python/socsec_git.bb
@@ -4,20 +4,20 @@ HOMEPAGE = "https://github.com/AspeedTech-BMC/socsec/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d50b901333b4eedfee074ebcd6a6d611"
-SRC_URI = "git://github.com/AspeedTech-BMC/socsec/;protocol=https;branch=develop"
+SRC_URI = "git://github.com/AspeedTech-BMC/socsec/;protocol=https;branch=master"
-PV = "1.7+git${SRCPV}"
-SRCREV = "54cdd3b26262e66d2020a04cba55bc8b02090f1a"
+PV = "0.2.1+git${SRCPV}"
+SRCREV = "51bd4504bffb5044264cfe4c63b8fe8d48a114a9"
S = "${WORKDIR}/git"
inherit python3native setuptools3
-RDEPENDS_${PN} += "python3-bitarray"
-RDEPENDS_${PN} += "python3-core"
-RDEPENDS_${PN} += "python3-hexdump"
-RDEPENDS_${PN} += "python3-jsonschema"
-RDEPENDS_${PN} += "python3-jstyleson"
-RDEPENDS_${PN} += "python3-pycryptodome"
+RDEPENDS:${PN} += "python3-bitarray"
+RDEPENDS:${PN} += "python3-core"
+RDEPENDS:${PN} += "python3-ecdsa"
+RDEPENDS:${PN} += "python3-jsonschema"
+RDEPENDS:${PN} += "python3-jstyleson"
+RDEPENDS:${PN} += "python3-pycryptodome"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
index 727c62d27..6f2d979bc 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
@@ -3,25 +3,31 @@ require u-boot-common-aspeed-sdk_${PV}.inc
UBOOT_MAKE_TARGET ?= "DEVICE_TREE=${UBOOT_DEVICETREE}"
require u-boot-aspeed.inc
-inherit socsec-sign
PROVIDES += "u-boot"
DEPENDS += "bc-native dtc-native"
-SRC_URI_append_df-phosphor-mmc = " file://u-boot-env-ast2600.txt"
+SRC_URI:append:df-phosphor-mmc = " file://u-boot-env-ast2600.txt"
SRC_URI += " \
file://rsa_oem_dss_key.pem;sha256sum=64a379979200d39949d3e5b0038e3fdd5548600b2f7077a17e35422336075ad4 \
file://rsa_pub_oem_dss_key.pem;sha256sum=40132a694a10af2d1b094b1cb5adab4d6b4db2a35e02d848b2b6a85e60738264 \
"
-UBOOT_ENV_SIZE_df-phosphor-mmc = "0x10000"
-UBOOT_ENV_df-phosphor-mmc = "u-boot-env"
-UBOOT_ENV_SUFFIX_df-phosphor-mmc = "bin"
+SOCSEC_SIGN_KEY ?= "${WORKDIR}/rsa_oem_dss_key.pem"
+SOCSEC_SIGN_ALGO ?= "RSA4096_SHA512"
+SOCSEC_SIGN_EXTRA_OPTS ?= "--stack_intersects_verification_region=false"
+
+inherit socsec-sign
+
+UBOOT_ENV_SIZE:df-phosphor-mmc = "0x10000"
+UBOOT_ENV:df-phosphor-mmc = "u-boot-env"
+UBOOT_ENV_SUFFIX:df-phosphor-mmc = "bin"
+UBOOT_ENV_TXT:df-phosphor-mmc = "u-boot-env-ast2600.txt"
-do_compile_append() {
+do_compile:append() {
if [ -n "${UBOOT_ENV}" ]
then
# Generate redundant environment image
- ${B}/tools/mkenvimage -r -s ${UBOOT_ENV_SIZE} -o ${WORKDIR}/${UBOOT_ENV_BINARY} ${WORKDIR}/u-boot-env-ast2600.txt
+ ${B}/tools/mkenvimage -r -s ${UBOOT_ENV_SIZE} -o ${WORKDIR}/${UBOOT_ENV_BINARY} ${WORKDIR}/${UBOOT_ENV_TXT}
fi
}
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
index 0b9bc20d2..3028a9e19 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed.inc
@@ -182,7 +182,11 @@ do_install () {
}
-FILES_${PN} = "/boot ${sysconfdir} ${datadir}"
+PACKAGE_BEFORE_PN += "${PN}-env"
+
+RPROVIDES:${PN}-env += "u-boot-default-env"
+FILES:${PN} = "/boot ${sysconfdir} ${datadir}"
+RDEPENDS:${PN} += "${PN}-env"
do_deploy () {
if [ -n "${UBOOT_CONFIG}" ]
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
index 8cebe5ab3..395f5ab57 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
@@ -6,4 +6,4 @@ DEPENDS += "dtc-native"
# FIXME this can/should be removed when we have rebased off our
# 2016 snapshot onto a more modern (circa late 2018) u-boot tree.
-BUILD_CFLAGS_remove = "-isystem${STAGING_INCDIR_NATIVE}"
+BUILD_CFLAGS:remove = "-isystem${STAGING_INCDIR_NATIVE}"
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index cebbee6e6..6c1470a5f 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -4,16 +4,17 @@ SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
DEPENDS += "mtd-utils"
PROVIDES += "u-boot-fw-utils"
+RPROVIDES:${PN} += "u-boot-fw-utils"
SRC_URI += "file://fw_env_ast2600_nor.config"
SRC_URI += "file://fw_env_ast2600_mmc.config"
ENV_CONFIG_FILE = "fw_env_ast2600_nor.config"
-ENV_CONFIG_FILE_df-phosphor-mmc = "fw_env_ast2600_mmc.config"
+ENV_CONFIG_FILE:df-phosphor-mmc = "fw_env_ast2600_mmc.config"
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+INSANE_SKIP:${PN} = "already-stripped"
+EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE:class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config
@@ -31,13 +32,13 @@ do_install () {
install -m 644 ${WORKDIR}/${ENV_CONFIG_FILE} ${D}${sysconfdir}/fw_env.config
}
-do_install_class-cross () {
+do_install:class-cross () {
install -d ${D}${bindir_cross}
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
}
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
BBCLASSEXTEND = "cross"
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
index e9f724df2..0ec64ce8e 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb
@@ -9,9 +9,9 @@ DEPENDS += "mtd-utils"
PROVIDES += "u-boot-fw-utils"
-INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+INSANE_SKIP:${PN} = "already-stripped"
+EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE:class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config
@@ -30,15 +30,15 @@ do_install () {
install -m 644 ${WORKDIR}/alt_fw_env.config ${D}${sysconfdir}/alt_fw_env.config
}
-do_install_class-cross () {
+do_install:class-cross () {
install -d ${D}${bindir_cross}
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
}
-SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
BBCLASSEXTEND = "cross"
-RDEPENDS_${PN} = "udev-aspeed-mtd-partitions"
+RDEPENDS:${PN} = "udev-aspeed-mtd-partitions"
diff --git a/meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb b/meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb
index 9e85308cd..3f30916bd 100644
--- a/meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb
+++ b/meta-aspeed/recipes-core/udev/udev-aspeed-mtd-partitions.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
S = "${WORKDIR}"
SRC_URI += "file://76-aspeed-mtd-partitions.rules"
-RDEPENDS_${PN} += "udev"
+RDEPENDS:${PN} += "udev"
do_install() {
- install -d ${D}/${base_libdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/76-aspeed-mtd-partitions.rules ${D}/${base_libdir}/udev/rules.d
+ install -d ${D}/${nonarch_base_libdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/76-aspeed-mtd-partitions.rules ${D}/${nonarch_base_libdir}/udev/rules.d
}
diff --git a/meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb b/meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb
index c0ee6771e..44cafca8c 100644
--- a/meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb
+++ b/meta-aspeed/recipes-core/udev/udev-aspeed-vuart.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
S = "${WORKDIR}"
SRC_URI += "file://61-aspeed-vuart.rules"
-RDEPENDS_${PN} += "udev"
+RDEPENDS:${PN} += "udev"
do_install() {
- install -d ${D}/lib/udev/rules.d
- install -m 0644 ${WORKDIR}/61-aspeed-vuart.rules ${D}/lib/udev/rules.d
+ install -d ${D}/${nonarch_base_libdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/61-aspeed-vuart.rules ${D}/${nonarch_base_libdir}/udev/rules.d
}
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
index 208031f1c..b7d3c4587 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
@@ -1,6 +1,6 @@
KBRANCH ?= "dev-5.10"
-LINUX_VERSION ?= "5.10.53"
+LINUX_VERSION ?= "5.10.60"
-SRCREV="1519240139a91e3dbc97d8f79de29a22a3328257"
+SRCREV="09869b9b34417297808d8a57b2e9f8f61218354b"
require linux-aspeed.inc