summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-bletchley/recipes-bletchley/plat-svc/plat-svc_0.1.bb
diff options
context:
space:
mode:
authorHoward Chiu <howard.chiu@quantatw.com>2021-12-09 08:27:04 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-12-22 19:16:58 +0300
commit0eb09a13b1e395c0ff09d794cc11bd1513a6b935 (patch)
treefcbdf1664f22fde8c1a669db51305c8e302279b4 /meta-facebook/meta-bletchley/recipes-bletchley/plat-svc/plat-svc_0.1.bb
parentda05a16b41d429bd7c1229b377b8bfa948d61281 (diff)
downloadopenbmc-0eb09a13b1e395c0ff09d794cc11bd1513a6b935.tar.xz
meta-bletchley: Add init service to setup system
To setup GPIOs and set fan speed to 70% Signed-off-by: Howard Chiu <howard.chiu@quantatw.com> Signed-off-by: Potin Lai <potin.lai@quantatw.com> Change-Id: I7a64e19b6e34bcab7013b382d19d7be6156bf87a
Diffstat (limited to 'meta-facebook/meta-bletchley/recipes-bletchley/plat-svc/plat-svc_0.1.bb')
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/plat-svc/plat-svc_0.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/plat-svc/plat-svc_0.1.bb b/meta-facebook/meta-bletchley/recipes-bletchley/plat-svc/plat-svc_0.1.bb
new file mode 100644
index 000000000..dcbf6e88a
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-bletchley/plat-svc/plat-svc_0.1.bb
@@ -0,0 +1,25 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch systemd
+
+RDEPENDS:${PN} += "bash"
+RDEPENDS:${PN} += "libgpiod-tools"
+
+SRC_URI += " \
+ file://bletchley-early-sys-init \
+ file://bletchley-sys-init.service \
+ "
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN}:append = " \
+ bletchley-sys-init.service \
+ "
+
+do_install() {
+ install -d ${D}${libexecdir}
+ install -m 0755 ${WORKDIR}/bletchley-early-sys-init ${D}${libexecdir}
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/bletchley-sys-init.service ${D}${systemd_system_unitdir}
+}