summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb
diff options
context:
space:
mode:
authorPotin Lai <potin.lai@quantatw.com>2021-12-16 19:47:35 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-12-20 16:39:02 +0300
commit538683f3af153b0a3381790a7bfbd2696b17f9d5 (patch)
tree692b0f2f34fd7bc29898e5fb8a6038e09d7be215 /meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb
parenta7d72d713cff6d14225eb39b35d7150aef479e0d (diff)
downloadopenbmc-538683f3af153b0a3381790a7bfbd2696b17f9d5.tar.xz
meta-bletchley: add led manager
add support of phosphor-led-manager for Bletchley Signed-off-by: Potin Lai <potin.lai@quantatw.com> Change-Id: I4c27fb1a7658b89ff20f8f2ee4c38ae5bd17ffc0
Diffstat (limited to 'meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb')
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb b/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb
new file mode 100644
index 000000000..d06ec861e
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/leds/bletchley-led-manager-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor LED Group Management for Bletchley"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Copies example led layout yaml file
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}