summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-tiogapass
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2020-09-25 18:54:11 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-11-03 23:32:06 +0300
commit2ec55731645b2a536c90d3da383c7900a2c23e0f (patch)
tree65d7ebd664f7eb97e458aba2ffd121530ce6c4f2 /meta-facebook/meta-tiogapass
parent5c30e3722e370fe60bc4c6eeacd87eb0fa3aa3ea (diff)
downloadopenbmc-2ec55731645b2a536c90d3da383c7900a2c23e0f.tar.xz
meta-facebook: tiogapass: add U-Boot patch to match EFI firmware baud rate
This adds a tiogapass-specific patch so that U-Boot and kernel console are using 57600 to match EFI firmware baud rate. (From meta-facebook rev: f552fa78ddbf0364fc393cdbc214d8b1742288b3) Signed-off-by: Paul Fertser <fercerpav@gmail.com> Change-Id: I73e313aad7abd9d3361e14fb560a7b3f41539e55 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-facebook/meta-tiogapass')
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch39
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend2
3 files changed, 43 insertions, 0 deletions
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch
new file mode 100644
index 000000000..4bec6c8d5
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch
@@ -0,0 +1,39 @@
+From 44cdd36855728059e58dcad52b42d825bb1cc2af Mon Sep 17 00:00:00 2001
+From: Paul Fertser <fercerpav@gmail.com>
+Date: Fri, 25 Sep 2020 18:36:45 +0300
+Subject: [PATCH] configs/ast-common: use 57600 baud rate to match Tioga Pass
+ EFI firmware
+
+This is a Tioga Pass specific patch, only for
+meta-facebook/meta-tiogapass layer.
+
+Signed-off-by: Paul Fertser <fercerpav@gmail.com>
+---
+ include/configs/ast-common.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/configs/ast-common.h b/include/configs/ast-common.h
+index a0243083bd..f0f2ae08b6 100644
+--- a/include/configs/ast-common.h
++++ b/include/configs/ast-common.h
+@@ -56,7 +56,7 @@
+ #define CONFIG_SYS_LOADS_BAUD_CHANGE
+ #define CONFIG_SERIAL1 1
+ #define CONFIG_CONS_INDEX 1
+-#define CONFIG_BAUDRATE 115200
++#define CONFIG_BAUDRATE 57600
+
+ /*
+ * BOOTP options
+@@ -96,7 +96,7 @@
+ #define CONFIG_CMD_MTDPARTS
+ #endif
+
+-#define CONFIG_BOOTARGS "console=ttyS4,115200n8 root=/dev/ram rw"
++#define CONFIG_BOOTARGS "console=ttyS4,57600n8 root=/dev/ram rw"
+
+ #define CONFIG_AST_SPI_NOR /* AST SPI NOR Flash */
+ #define CONFIG_FMC_CS 1
+--
+2.17.1
+
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
new file mode 100644
index 000000000..b9bf0af2a
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch"
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend
new file mode 100644
index 000000000..f24fe5e4f
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot-aspeed:"
+SRC_URI += "file://0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch"