summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-tiogapass
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 15:40:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-07 00:08:56 +0300
commit6f7466418cc95a27f07ae932fa6fdd56e9c7f90d (patch)
tree5e7fcef77fd6406ba611311dfd5587d9bab5705c /meta-facebook/meta-tiogapass
parente5b39f63e81a697edd5d5958665c7f55b71cd133 (diff)
downloadopenbmc-6f7466418cc95a27f07ae932fa6fdd56e9c7f90d.tar.xz
meta-facebook: prep for new override syntax
Ran `scripts/contrib/convert-overrides.py` from upstream Yocto and fixed up a few by hand that were missed. Tested: Built bletchley and tiogapass. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I0489ba007132901697e4ef1a29b03a3591b3ee3b
Diffstat (limited to 'meta-facebook/meta-tiogapass')
-rw-r--r--meta-facebook/meta-tiogapass/conf/layer.conf4
-rw-r--r--meta-facebook/meta-tiogapass/conf/local.conf.sample8
-rw-r--r--meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog_%.bbappend8
-rw-r--r--meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed_%.bbappend2
7 files changed, 14 insertions, 14 deletions
diff --git a/meta-facebook/meta-tiogapass/conf/layer.conf b/meta-facebook/meta-tiogapass/conf/layer.conf
index 94db7e114..34cb1eb2b 100644
--- a/meta-facebook/meta-tiogapass/conf/layer.conf
+++ b/meta-facebook/meta-tiogapass/conf/layer.conf
@@ -6,6 +6,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "tiogapass-layer"
-BBFILE_PATTERN_tiogapass-layer := "^${LAYERDIR}/"
+BBFILE_PATTERN:tiogapass-layer := "^${LAYERDIR}/"
-LAYERSERIES_COMPAT_tiogapass-layer := "gatesgarth hardknott"
+LAYERSERIES_COMPAT:tiogapass-layer := "gatesgarth hardknott"
diff --git a/meta-facebook/meta-tiogapass/conf/local.conf.sample b/meta-facebook/meta-tiogapass/conf/local.conf.sample
index 641963aed..c7b9c3c64 100644
--- a/meta-facebook/meta-tiogapass/conf/local.conf.sample
+++ b/meta-facebook/meta-tiogapass/conf/local.conf.sample
@@ -65,7 +65,7 @@ MACHINE ??= "tiogapass"
#
DISTRO ?= "openbmc-phosphor"
# As an example of a subclass there is a "bleeding" edge policy configuration
-# where many versions are set to the absolute latest code from the upstream
+# where many versions are set to the absolute latest code from the upstream
# source control systems. This is just mentioned here as an example, its not
# useful to most new users.
# DISTRO ?= "poky-bleeding"
@@ -93,7 +93,7 @@ PACKAGE_CLASSES ?= "package_rpm"
# Supported values are i686 and x86_64
#SDKMACHINE ?= "i686"
-SANITY_TESTED_DISTROS_append ?= " *"
+SANITY_TESTED_DISTROS:append ?= " *"
#
# Extra image configuration defaults
@@ -204,8 +204,8 @@ BB_DISKMON_DIRS = "\
# By default qemu will build with a builtin VNC server where graphical output can be
# seen. The two lines below enable the SDL backend too. This assumes there is a
# libsdl library available on your build system.
-#PACKAGECONFIG_append_pn-qemu-native = " sdl"
-#PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
+#PACKAGECONFIG:append:pn-qemu-native = " sdl"
+#PACKAGECONFIG:append:pn-nativesdk-qemu = " sdl"
#ASSUME_PROVIDED += "libsdl-native"
diff --git a/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf b/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf
index 1e6ee084b..deaf0f28e 100644
--- a/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf
+++ b/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf
@@ -9,5 +9,5 @@ require conf/machine/include/obmc-bsp-common.inc
SERIAL_CONSOLES = "57600;ttyS4"
-PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= ""
+PREFERRED_PROVIDER:virtual/obmc-host-ctl ?= ""
FLASH_SIZE = "32768"
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
index b9bf0af2a..db85451db 100644
--- a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch"
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend
index f24fe5e4f..d66a385e6 100644
--- a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot-aspeed:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-aspeed:"
SRC_URI += "file://0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch"
diff --git a/meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog_%.bbappend b/meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog_%.bbappend
index eeeea1a30..104d13b4a 100644
--- a/meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog_%.bbappend
+++ b/meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://rsyslog.conf \
file://rsyslog.logrotate \
@@ -6,12 +6,12 @@ SRC_URI += "file://rsyslog.conf \
file://rotate-event-logs.timer \
"
-PACKAGECONFIG_append = " imjournal"
+PACKAGECONFIG:append = " imjournal"
-do_install_append() {
+do_install:append() {
install -m 0644 ${WORKDIR}/rotate-event-logs.service ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/rotate-event-logs.timer ${D}${systemd_system_unitdir}
rm ${D}${sysconfdir}/rsyslog.d/imjournal.conf
}
-SYSTEMD_SERVICE_${PN} += " rotate-event-logs.service rotate-event-logs.timer"
+SYSTEMD_SERVICE:${PN} += " rotate-event-logs.service rotate-event-logs.timer"
diff --git a/meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed_%.bbappend
index 0eb088404..df490bc84 100644
--- a/meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux-aspeed:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux-aspeed:"
SRC_URI += "file://tiogapass.cfg"