summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-yosemitev2
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 15:40:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-07 00:08:56 +0300
commit6f7466418cc95a27f07ae932fa6fdd56e9c7f90d (patch)
tree5e7fcef77fd6406ba611311dfd5587d9bab5705c /meta-facebook/meta-yosemitev2
parente5b39f63e81a697edd5d5958665c7f55b71cd133 (diff)
downloadopenbmc-6f7466418cc95a27f07ae932fa6fdd56e9c7f90d.tar.xz
meta-facebook: prep for new override syntax
Ran `scripts/contrib/convert-overrides.py` from upstream Yocto and fixed up a few by hand that were missed. Tested: Built bletchley and tiogapass. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I0489ba007132901697e4ef1a29b03a3591b3ee3b
Diffstat (limited to 'meta-facebook/meta-yosemitev2')
-rw-r--r--meta-facebook/meta-yosemitev2/conf/layer.conf4
-rw-r--r--meta-facebook/meta-yosemitev2/conf/local.conf.sample8
-rw-r--r--meta-facebook/meta-yosemitev2/conf/machine/yosemitev2.conf2
-rw-r--r--meta-facebook/meta-yosemitev2/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend2
-rw-r--r--meta-facebook/meta-yosemitev2/recipes-kernel/linux/linux-aspeed_%.bbappend2
5 files changed, 9 insertions, 9 deletions
diff --git a/meta-facebook/meta-yosemitev2/conf/layer.conf b/meta-facebook/meta-yosemitev2/conf/layer.conf
index 977d5df67..9144ca541 100644
--- a/meta-facebook/meta-yosemitev2/conf/layer.conf
+++ b/meta-facebook/meta-yosemitev2/conf/layer.conf
@@ -6,6 +6,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "yosemitev2-layer"
-BBFILE_PATTERN_yosemitev2-layer := "^${LAYERDIR}/"
+BBFILE_PATTERN:yosemitev2-layer := "^${LAYERDIR}/"
-LAYERSERIES_COMPAT_yosemitev2-layer := "gatesgarth hardknott"
+LAYERSERIES_COMPAT:yosemitev2-layer := "gatesgarth hardknott"
diff --git a/meta-facebook/meta-yosemitev2/conf/local.conf.sample b/meta-facebook/meta-yosemitev2/conf/local.conf.sample
index 297d077cc..c9dffc2e4 100644
--- a/meta-facebook/meta-yosemitev2/conf/local.conf.sample
+++ b/meta-facebook/meta-yosemitev2/conf/local.conf.sample
@@ -65,7 +65,7 @@ MACHINE ??= "yosemitev2"
#
DISTRO ?= "openbmc-phosphor"
# As an example of a subclass there is a "bleeding" edge policy configuration
-# where many versions are set to the absolute latest code from the upstream
+# where many versions are set to the absolute latest code from the upstream
# source control systems. This is just mentioned here as an example, its not
# useful to most new users.
# DISTRO ?= "poky-bleeding"
@@ -93,7 +93,7 @@ PACKAGE_CLASSES ?= "package_rpm"
# Supported values are i686 and x86_64
#SDKMACHINE ?= "i686"
-SANITY_TESTED_DISTROS_append ?= " *"
+SANITY_TESTED_DISTROS:append ?= " *"
#
# Extra image configuration defaults
@@ -204,8 +204,8 @@ BB_DISKMON_DIRS = "\
# By default qemu will build with a builtin VNC server where graphical output can be
# seen. The two lines below enable the SDL backend too. This assumes there is a
# libsdl library available on your build system.
-#PACKAGECONFIG_append_pn-qemu-native = " sdl"
-#PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
+#PACKAGECONFIG:append:pn-qemu-native = " sdl"
+#PACKAGECONFIG:append:pn-nativesdk-qemu = " sdl"
#ASSUME_PROVIDED += "libsdl-native"
diff --git a/meta-facebook/meta-yosemitev2/conf/machine/yosemitev2.conf b/meta-facebook/meta-yosemitev2/conf/machine/yosemitev2.conf
index d246cc9b3..9119189bc 100644
--- a/meta-facebook/meta-yosemitev2/conf/machine/yosemitev2.conf
+++ b/meta-facebook/meta-yosemitev2/conf/machine/yosemitev2.conf
@@ -9,6 +9,6 @@ require conf/machine/include/obmc-bsp-common.inc
SERIAL_CONSOLES = "57600;ttyS4"
-PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= ""
+PREFERRED_PROVIDER:virtual/obmc-host-ctl ?= ""
FLASH_SIZE = "32768"
OBMC_HOST_INSTANCES = "1 2 3 4"
diff --git a/meta-facebook/meta-yosemitev2/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-facebook/meta-yosemitev2/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
index 1c38b11ba..298738f04 100644
--- a/meta-facebook/meta-yosemitev2/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
+++ b/meta-facebook/meta-yosemitev2/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
@@ -1,3 +1,3 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI +="file://0001-board-aspeed-Add-Mux-for-yosemitev2.patch"
SRC_URI +="file://0002-spl-host-console-handle.patch"
diff --git a/meta-facebook/meta-yosemitev2/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-facebook/meta-yosemitev2/recipes-kernel/linux/linux-aspeed_%.bbappend
index 9020b66fb..299aebaf2 100644
--- a/meta-facebook/meta-yosemitev2/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-facebook/meta-yosemitev2/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux-aspeed:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux-aspeed:"
SRC_URI += "file://yosemitev2.cfg"