summaryrefslogtreecommitdiff
path: root/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 15:40:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-07 00:08:56 +0300
commit6f7466418cc95a27f07ae932fa6fdd56e9c7f90d (patch)
tree5e7fcef77fd6406ba611311dfd5587d9bab5705c /meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
parente5b39f63e81a697edd5d5958665c7f55b71cd133 (diff)
downloadopenbmc-6f7466418cc95a27f07ae932fa6fdd56e9c7f90d.tar.xz
meta-facebook: prep for new override syntax
Ran `scripts/contrib/convert-overrides.py` from upstream Yocto and fixed up a few by hand that were missed. Tested: Built bletchley and tiogapass. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I0489ba007132901697e4ef1a29b03a3591b3ee3b
Diffstat (limited to 'meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend')
-rw-r--r--meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend b/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
index f0a1c7be8..266614079 100644
--- a/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
OBMC_CONSOLE_HOST_TTY = "ttyS2"
-SRC_URI_append_tiogapass = " file://server.ttyS2.conf"
-SRC_URI_append_yosemitev2 = " file://server.ttyS0.conf \
+SRC_URI:append:tiogapass = " file://server.ttyS2.conf"
+SRC_URI:append:yosemitev2 = " file://server.ttyS0.conf \
file://server.ttyS1.conf \
file://server.ttyS2.conf \
file://server.ttyS3.conf \
@@ -11,12 +11,12 @@ SRC_URI_append_yosemitev2 = " file://server.ttyS0.conf \
file://client.2202.conf \
file://client.2203.conf"
-SRC_URI_remove = "file://${BPN}.conf"
+SRC_URI:remove = "file://${BPN}.conf"
-SYSTEMD_SERVICE_${PN}_remove_yosemitev2 = "obmc-console-ssh.socket"
-EXTRA_OECONF_append_yosemitev2 = " --enable-concurrent-servers"
+SYSTEMD_SERVICE:${PN}:remove:yosemitev2 = "obmc-console-ssh.socket"
+EXTRA_OECONF:append:yosemitev2 = " --enable-concurrent-servers"
-do_install_append() {
+do_install:append() {
# Install the server configuration
install -m 0755 -d ${D}${sysconfdir}/${BPN}
install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/