summaryrefslogtreecommitdiff
path: root/meta-google/recipes-core/dropbear
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2021-02-10 03:31:28 +0300
committerWilly Tu <wltu@google.com>2021-03-30 01:58:34 +0300
commit08fd8660acf19ad6e274665051bc8377185e18cb (patch)
tree5165f187d8669c4feb58ee3fb3ae7ea3d40345cb /meta-google/recipes-core/dropbear
parentbc0236c1dbd3766375b795d01905802929cf9392 (diff)
downloadopenbmc-08fd8660acf19ad6e274665051bc8377185e18cb.tar.xz
meta-google: recipes-core: dropbear: Import from gBMC
Update recipes-core/dropbear code from gBMC. Google-Bug-Id: 179618554 Upstream: 8ac594bdf054082ca6dbe35c4345759fe4c31669 Signed-off-by: Willy Tu <wltu@google.com> Change-Id: I56886cf316ebc5f77e0f5afdc0bcc970d7cf490e
Diffstat (limited to 'meta-google/recipes-core/dropbear')
-rw-r--r--meta-google/recipes-core/dropbear/dropbear/dropbear.default1
-rw-r--r--meta-google/recipes-core/dropbear/dropbear_%.bbappend7
2 files changed, 8 insertions, 0 deletions
diff --git a/meta-google/recipes-core/dropbear/dropbear/dropbear.default b/meta-google/recipes-core/dropbear/dropbear/dropbear.default
new file mode 100644
index 000000000..e5f778145
--- /dev/null
+++ b/meta-google/recipes-core/dropbear/dropbear/dropbear.default
@@ -0,0 +1 @@
+DROPBEAR_EXTRA_ARGS=""
diff --git a/meta-google/recipes-core/dropbear/dropbear_%.bbappend b/meta-google/recipes-core/dropbear/dropbear_%.bbappend
index 20c53fecb..e93eba8b6 100644
--- a/meta-google/recipes-core/dropbear/dropbear_%.bbappend
+++ b/meta-google/recipes-core/dropbear/dropbear_%.bbappend
@@ -1,3 +1,10 @@
+FILESEXTRAPATHS_prepend_gbmc := "${THISDIR}/${PN}:"
+SRC_URI_append_gbmc = " file://dropbear.default"
+SYSTEMD_AUTO_ENABLE_${PN}_prod = "disable"
+
+FILESEXTRAPATHS_remove_gbmc_bandaid := "${THISDIR}/${PN}:"
+SYSTEMD_AUTO_ENABLE_${PN}_bandaid_prod = "enable"
+
# Allow SSH to the mgmt node on DEV builds
do_install_append_gbmc_dev() {
nftables_dir=${D}${sysconfdir}/nftables