summaryrefslogtreecommitdiff
path: root/meta-google/recipes-core
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2021-02-10 03:27:00 +0300
committerWilly Tu <wltu@google.com>2021-02-11 00:55:38 +0300
commit0d84c227694b49723552cd5e57e9168c61121d82 (patch)
treedf82a6f52415495b67e3d519935c800825803b90 /meta-google/recipes-core
parent7354cf7e664c248eb0b043138657ff8739cc456b (diff)
downloadopenbmc-0d84c227694b49723552cd5e57e9168c61121d82.tar.xz
meta-google: recipes-core: busybox: Import from gBMC
Initial recipes-core/busybox code from gBMC. Google-Bug-Id: 179618494 Upstream: 8ac594bdf054082ca6dbe35c4345759fe4c31669 Change-Id: Iab31d541d0130e9c1da7b7289383ecd66353f30c Signed-off-by: Willy Tu <wltu@google.com>
Diffstat (limited to 'meta-google/recipes-core')
-rw-r--r--meta-google/recipes-core/busybox/busybox_%.bbappend6
-rw-r--r--meta-google/recipes-core/busybox/files/ip.cfg1
-rw-r--r--meta-google/recipes-core/busybox/files/ls.cfg1
-rw-r--r--meta-google/recipes-core/busybox/files/udhcpc6.cfg6
4 files changed, 14 insertions, 0 deletions
diff --git a/meta-google/recipes-core/busybox/busybox_%.bbappend b/meta-google/recipes-core/busybox/busybox_%.bbappend
new file mode 100644
index 000000000..38863ec45
--- /dev/null
+++ b/meta-google/recipes-core/busybox/busybox_%.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend_gbmc := "${THISDIR}/files:"
+SRC_URI_append_gbmc = " \
+ file://udhcpc6.cfg \
+ file://ip.cfg \
+ file://ls.cfg \
+"
diff --git a/meta-google/recipes-core/busybox/files/ip.cfg b/meta-google/recipes-core/busybox/files/ip.cfg
new file mode 100644
index 000000000..f9357715e
--- /dev/null
+++ b/meta-google/recipes-core/busybox/files/ip.cfg
@@ -0,0 +1 @@
+CONFIG_IPNEIGH=y
diff --git a/meta-google/recipes-core/busybox/files/ls.cfg b/meta-google/recipes-core/busybox/files/ls.cfg
new file mode 100644
index 000000000..a302cb8b1
--- /dev/null
+++ b/meta-google/recipes-core/busybox/files/ls.cfg
@@ -0,0 +1 @@
+CONFIG_LSOF=y
diff --git a/meta-google/recipes-core/busybox/files/udhcpc6.cfg b/meta-google/recipes-core/busybox/files/udhcpc6.cfg
new file mode 100644
index 000000000..1c2766fda
--- /dev/null
+++ b/meta-google/recipes-core/busybox/files/udhcpc6.cfg
@@ -0,0 +1,6 @@
+CONFIG_FEATURE_IPV6=y
+CONFIG_UDHCPC6=y
+CONFIG_FEATURE_UDHCPC6_RFC3646=y
+CONFIG_FEATURE_UDHCPC6_RFC4704=y
+CONFIG_FEATURE_UDHCPC6_RFC4833=y
+CONFIG_FEATURE_UDHCPC6_RFC5970=y