summaryrefslogtreecommitdiff
path: root/meta-google/recipes-core
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-03-10 09:31:01 +0300
committerWilliam A. Kennington III <wak@google.com>2021-03-10 22:00:49 +0300
commitf7ef633d5f6a9144acdf60af1dacd7a351c9abb5 (patch)
tree8eacb8ea664dbd3e7512742d8219c00e182472d9 /meta-google/recipes-core
parenta17fe81f0797df9fbd889ac8f7866a984d299829 (diff)
downloadopenbmc-f7ef633d5f6a9144acdf60af1dacd7a351c9abb5.tar.xz
busybox: Consolidate rules into a single file
Change-Id: I0fad530d23558737b4217ab604fc31098ac06254 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-core')
-rw-r--r--meta-google/recipes-core/busybox/busybox_%.bbappend7
-rw-r--r--meta-google/recipes-core/busybox/files/gbmc.cfg (renamed from meta-google/recipes-core/busybox/files/udhcpc6.cfg)9
-rw-r--r--meta-google/recipes-core/busybox/files/ip.cfg2
-rw-r--r--meta-google/recipes-core/busybox/files/ls.cfg1
-rw-r--r--meta-google/recipes-core/busybox/files/lsusb.cfg1
5 files changed, 10 insertions, 10 deletions
diff --git a/meta-google/recipes-core/busybox/busybox_%.bbappend b/meta-google/recipes-core/busybox/busybox_%.bbappend
index affe663e7..9d8cb2d97 100644
--- a/meta-google/recipes-core/busybox/busybox_%.bbappend
+++ b/meta-google/recipes-core/busybox/busybox_%.bbappend
@@ -1,7 +1,2 @@
FILESEXTRAPATHS_prepend_gbmc := "${THISDIR}/files:"
-SRC_URI_append_gbmc = " \
- file://udhcpc6.cfg \
- file://ip.cfg \
- file://ls.cfg \
- file://lsusb.cfg \
-"
+SRC_URI_append_gbmc = " file://gbmc.cfg"
diff --git a/meta-google/recipes-core/busybox/files/udhcpc6.cfg b/meta-google/recipes-core/busybox/files/gbmc.cfg
index 1c2766fda..51d15d1c7 100644
--- a/meta-google/recipes-core/busybox/files/udhcpc6.cfg
+++ b/meta-google/recipes-core/busybox/files/gbmc.cfg
@@ -1,3 +1,12 @@
+# gBMC uses iproute2
+CONFIG_IP=n
+CONFIG_NETSTAT=n
+
+# Debugging utilities
+CONFIG_LSOF=y
+CONFIG_LSUSB=y
+
+# Used by NC-SId
CONFIG_FEATURE_IPV6=y
CONFIG_UDHCPC6=y
CONFIG_FEATURE_UDHCPC6_RFC3646=y
diff --git a/meta-google/recipes-core/busybox/files/ip.cfg b/meta-google/recipes-core/busybox/files/ip.cfg
deleted file mode 100644
index e8acf56b5..000000000
--- a/meta-google/recipes-core/busybox/files/ip.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-CONFIG_IP=n
-CONFIG_NETSTAT=n
diff --git a/meta-google/recipes-core/busybox/files/ls.cfg b/meta-google/recipes-core/busybox/files/ls.cfg
deleted file mode 100644
index a302cb8b1..000000000
--- a/meta-google/recipes-core/busybox/files/ls.cfg
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_LSOF=y
diff --git a/meta-google/recipes-core/busybox/files/lsusb.cfg b/meta-google/recipes-core/busybox/files/lsusb.cfg
deleted file mode 100644
index 2aba6ef60..000000000
--- a/meta-google/recipes-core/busybox/files/lsusb.cfg
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_LSUSB=y