summaryrefslogtreecommitdiff
path: root/meta-google/recipes-extended
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-07-26 09:51:49 +0300
committerWilliam A. Kennington III <wak@google.com>2021-08-06 09:17:20 +0300
commite3f1bd88872db976ecf06e0167a4a3ae560a21f4 (patch)
treedbbf0e04d64938953ea6f124089d60ef6d8f0a9c /meta-google/recipes-extended
parent1c0f8e40203acb36a31b314f2218eca834849791 (diff)
downloadopenbmc-e3f1bd88872db976ecf06e0167a4a3ae560a21f4.tar.xz
meta-google: sslh: Ensure that autogenerated files aren't stale
These files sometimes get checked into the repo and we don't want non-determinism around their generation. Ensure they are cleaned up and regenerated for every build since that is very fast. Change-Id: If20c79f8308c117a20983c8cb54c3420d872d64b Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-extended')
-rw-r--r--meta-google/recipes-extended/libconfig/conf2struct-native_git.bb2
-rw-r--r--meta-google/recipes-extended/networking/sslh_git.bb13
2 files changed, 9 insertions, 6 deletions
diff --git a/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb b/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
index cf7f6f305..ab5c3d829 100644
--- a/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
+++ b/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
@@ -1,5 +1,5 @@
LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=1b886630cdc9a17c26250934beda407d"
+LIC_FILES_CHKSUM = "file://COPYING;md5=667d4ad55f5fbf4c3e853e8acd0f74de"
PV = "0.1+git${SRCPV}"
SRC_URI = "git://github.com/yrutschle/conf2struct"
diff --git a/meta-google/recipes-extended/networking/sslh_git.bb b/meta-google/recipes-extended/networking/sslh_git.bb
index 16c8f3279..ba26e2999 100644
--- a/meta-google/recipes-extended/networking/sslh_git.bb
+++ b/meta-google/recipes-extended/networking/sslh_git.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
PV = "0.1+git${SRCPV}"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
@@ -7,6 +7,9 @@ SRC_URI = "git://github.com/yrutschle/sslh"
SRCREV = "63f9c4a582f79f4d0e484efe0ccaeed77a79f7df"
S = "${WORKDIR}/git"
+inherit perlnative
+
+DEPENDS += "conf2struct-native"
DEPENDS += "libbsd"
DEPENDS += "libcap"
DEPENDS += "libconfig"
@@ -19,13 +22,13 @@ EXTRA_OEMAKE += "USELIBCAP=1"
EXTRA_OEMAKE += "USELIBBSD=1"
EXTRA_OEMAKE += "USESYSTEMD=1"
-do_patch() {
- # Workaround timestamps of the source being later than the generated,
- # vendored output files. This non-determinism sometimes causes failures.
- sed -i '/conf2struct/d' ${S}/Makefile
+do_configure() {
+ oe_runmake distclean
}
do_compile() {
+ # Workaround for the broken dependencies in the Makefile
+ oe_runmake sslh-conf.h
oe_runmake
}