summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/gpio/gpio-ctrl_git.bb
diff options
context:
space:
mode:
authorMichael Shen <gpgpgp@google.com>2021-08-05 05:14:46 +0300
committergpgpgp <gpgpgp@google.com>2021-08-10 18:06:33 +0300
commitcf7d39d3c07c9d18ccbee7cb12ffefdda50cce63 (patch)
tree3e68dbfda63e16a0c8f6989c2f973aae7eb0e4e0 /meta-google/recipes-google/gpio/gpio-ctrl_git.bb
parente26b91a8ff04d6550fc6a8ac115ad6805228a72f (diff)
downloadopenbmc-cf7d39d3c07c9d18ccbee7cb12ffefdda50cce63.tar.xz
meta-google: gpio-ctrl: upstream gpio-ctrl recipe
Add license to bb file and the copyright to shell script. Signed-off-by: Michael Shen <gpgpgp@google.com> Change-Id: I8b546ebfb302213c5a115af7220102fa51f2419b
Diffstat (limited to 'meta-google/recipes-google/gpio/gpio-ctrl_git.bb')
-rw-r--r--meta-google/recipes-google/gpio/gpio-ctrl_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-google/recipes-google/gpio/gpio-ctrl_git.bb b/meta-google/recipes-google/gpio/gpio-ctrl_git.bb
new file mode 100644
index 000000000..8241fc73d
--- /dev/null
+++ b/meta-google/recipes-google/gpio/gpio-ctrl_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "GPIO control library for bash scripts"
+DESCRIPTION = "GPIO control library for bash scripts."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+PR = "r1"
+
+SRC_URI += "file://lib.sh"
+
+RDEPENDS_${PN} = "bash"
+
+do_install() {
+ install -d ${D}${datadir}/gpio-ctrl
+ install -m 0755 ${WORKDIR}/lib.sh ${D}${datadir}/gpio-ctrl/
+}