summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb
diff options
context:
space:
mode:
authorTom Tung <tomtung@google.com>2021-08-06 10:20:42 +0300
committerTom Tung <shes050117@gmail.com>2021-08-10 08:18:12 +0300
commit959379abc1f2279ebc0a102b4091b0d775781747 (patch)
tree15d73e77ab449ae20c882d4fca13b315d0b297dd /meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb
parent48ea66bf4889bc86f19c9da78c342d2f18dbbabc (diff)
downloadopenbmc-959379abc1f2279ebc0a102b4091b0d775781747.tar.xz
meta-google: host-power-ctrl: Import libwatchdog from gBMC
Upstream package for libwatchdog. Change-Id: I9ef9243ae8e56a4a92be31c9229f1b38c00f662d Signed-off-by: Tom Tung <shes050117@gmail.com>
Diffstat (limited to 'meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb')
-rw-r--r--meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb b/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb
new file mode 100644
index 000000000..771f4b02a
--- /dev/null
+++ b/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Watchdog Shell Library"
+DESCRIPTION = "Watchdog Shell Library"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI += " \
+ file://libwatchdog.sh \
+"
+
+RDEPENDS_${PN} = "bash"
+
+do_install() {
+ install -d ${D}${libexecdir}
+ install -m 0755 ${WORKDIR}/libwatchdog.sh ${D}${libexecdir}/
+}