summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/nanopb
diff options
context:
space:
mode:
authorZhenfei Tai <ztai@google.com>2021-04-03 03:03:31 +0300
committerZhenfei Tai <ztai@google.com>2021-04-09 06:44:58 +0300
commitcd9f5f00d75fe3735eebe886a1e0701bb25ea967 (patch)
tree24b80e6f21b196604597dfe7417f032b790befe9 /meta-google/recipes-google/nanopb
parentf9995a8cf0d0096355ffc1c020e0617c40762f3f (diff)
downloadopenbmc-cd9f5f00d75fe3735eebe886a1e0701bb25ea967.tar.xz
meta-google: add nanopb recipe
We want to create a nanopb recipe instead of copying nanopb code into multiple recipes that need it. Signed-off-by: Zhenfei Tai <ztai@google.com> Change-Id: Id03695ccd1ef57f078eefb9e3638bbd802234e58
Diffstat (limited to 'meta-google/recipes-google/nanopb')
-rw-r--r--meta-google/recipes-google/nanopb/nanopb_0.4.5.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-google/recipes-google/nanopb/nanopb_0.4.5.bb b/meta-google/recipes-google/nanopb/nanopb_0.4.5.bb
new file mode 100644
index 000000000..232872e75
--- /dev/null
+++ b/meta-google/recipes-google/nanopb/nanopb_0.4.5.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Nanopb library"
+DESCRIPTION = "Nanopb - Protocol Buffers for Embedded Systems"
+HOMEPAGE = "https://github.com/nanopb/nanopb"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9db4b73a55a3994384112efcdb37c01f"
+
+inherit cmake python3native
+
+SRC_URI = "git://github.com/nanopb/nanopb"
+SRCREV = "f7e4140a27d9e63517b5d596bc117bd6d5248888"
+S = "${WORKDIR}/git"
+
+DEPENDS = "protobuf-native python3-protobuf"
+
+RDEPENDS_${PN}-generator += "python3 python3-protobuf"
+
+PACKAGES_prepend = "${PN}-generator ${PN}-runtime "
+
+FILES_${PN}-generator = "${libdir}/python* ${bindir}"
+
+FILES_${PN}-runtime = "${libdir}/*.so.*"
+
+BBCLASSEXTEND = "native"