summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-11-04 00:54:51 +0300
committerWilliam A. Kennington III <wak@google.com>2021-12-04 04:20:45 +0300
commitb174c185f31bf14d430e68bb868ccf14ff7d4be3 (patch)
treefda5ab522fc60af118cd4e286b195ba1fcc851ab /meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
parent21e7e45b77e026689b72f182aca4ba2ffd5e0a36 (diff)
downloadopenbmc-b174c185f31bf14d430e68bb868ccf14ff7d4be3.tar.xz
meta-google: gbmc-bridge: Implement DHCP
This makes it possible for a BMC to acquire a public address via DHCP provisioning. None of the update processes are included yet. Change-Id: I51ca2aa4859bcd2b9e909dd5a0d9e66cfbd648af Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb')
-rw-r--r--meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb b/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
index 0074a3172..6e2582495 100644
--- a/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
+++ b/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
@@ -20,6 +20,7 @@ SRC_URI += " \
file://gbmc-ncsi-br-pub-addr.sh.in \
file://gbmc-ncsi-br-deprecated-ips.sh.in \
file://gbmc-ncsi-set-nicenabled.service.in \
+ file://gbmc-ncsi-clear-ip.sh.in \
"
S = "${WORKDIR}"
@@ -36,6 +37,7 @@ RDEPENDS:${PN} += " \
"
FILES:${PN} += " \
+ ${datadir}/gbmc-br-dhcp \
${datadir}/gbmc-ip-monitor \
${systemd_unitdir} \
"
@@ -105,6 +107,12 @@ do_install:append() {
>${WORKDIR}/gbmc-ncsi-br-deprecated-ips.sh
install -m644 ${WORKDIR}/gbmc-ncsi-br-deprecated-ips.sh $mondir
+ dhcpdir=${D}${datadir}/gbmc-br-dhcp/
+ install -d -m0755 $dhcpdir
+ sed "s,@NCSI_IF@,$if_name,g" ${WORKDIR}/gbmc-ncsi-clear-ip.sh.in \
+ >${WORKDIR}/gbmc-ncsi-clear-ip.sh
+ install -m644 ${WORKDIR}/gbmc-ncsi-clear-ip.sh $dhcpdir
+
sed "s,@NCSI_IF@,$if_name,g" ${WORKDIR}/gbmc-ncsi-set-nicenabled.service.in \
>${D}${systemd_system_unitdir}/gbmc-ncsi-set-nicenabled.service