summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-03-11 10:40:47 +0300
committerWilliam A. Kennington III <wak@google.com>2021-05-07 04:09:53 +0300
commite99168aab003bd20a901f40e15823af6637a4abd (patch)
treebfb401d0f392b7b0aaef9feb774f3521701fceff /meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
parent1ef795b90e4d87f58553afbcf5928728ffb86e1b (diff)
downloadopenbmc-e99168aab003bd20a901f40e15823af6637a4abd.tar.xz
meta-google: gbmc-ncsi-config: Add public address to gbmc-bridge
This dynamically detects addresses applied to the NC-SI interface and infers the addreses which should be used explicitly by BMCs. Change-Id: I9036be0a54936aace580746cd1900ee653f43cfd Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb')
-rw-r--r--meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb b/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
index b833810f1..098819988 100644
--- a/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
+++ b/meta-google/recipes-google/ncsi/gbmc-ncsi-config.bb
@@ -10,6 +10,7 @@ SRC_URI += " \
file://gbmc-ncsi-sslh.socket.in \
file://gbmc-ncsi-sslh.service \
file://gbmc-ncsi-nft.sh.in \
+ file://gbmc-ncsi-br-pub-addr.sh.in \
"
S = "${WORKDIR}"
@@ -71,4 +72,7 @@ do_install_append() {
sed "s,@NCSI_IF@,$if_name,g" ${WORKDIR}/gbmc-ncsi-nft.sh.in \
>${WORKDIR}/gbmc-ncsi-nft.sh
install -m644 ${WORKDIR}/gbmc-ncsi-nft.sh $mondir
+ sed "s,@NCSI_IF@,$if_name,g" ${WORKDIR}/gbmc-ncsi-br-pub-addr.sh.in \
+ >${WORKDIR}/gbmc-ncsi-br-pub-addr.sh
+ install -m644 ${WORKDIR}/gbmc-ncsi-br-pub-addr.sh $mondir
}