summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
diff options
context:
space:
mode:
authorP Dheeraj Srujan Kumar <p.dheeraj.srujan.kumar@intel.com>2022-03-30 23:46:16 +0300
committerP Dheeraj Srujan Kumar <p.dheeraj.srujan.kumar@intel.com>2022-03-30 23:46:16 +0300
commit2af35ee50ce9918ee3626c59f2cff62cd3ab9568 (patch)
treebcc218f953c63222bff793a788b7922b9e39fb88 /meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
parent7cf0c1cd0ce835d1833509b7b911e8a97380278b (diff)
parent9248c75b142fa11243c20f4d200a04e4f6395b51 (diff)
downloadopenbmc-2af35ee50ce9918ee3626c59f2cff62cd3ab9568.tar.xz
Merge tag '1-0.91' of github.com:intel-innersource/firmware.bmc.openbmc.yocto.openbmc into update
Diffstat (limited to 'meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb')
-rw-r--r--meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb b/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
index 9e55afce5..418ee3932 100644
--- a/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
+++ b/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
@@ -10,8 +10,11 @@ inherit obmc-phosphor-systemd
PROVIDES += "virtual/bmc-update"
RPROVIDES:${PN} += "virtual/bmc-update"
-RDEPENDS:${PN} += "google-key"
-RDEPENDS:${PN} += "bash"
+RDEPENDS:${PN} += " \
+ bash \
+ gbmc-update \
+ google-key \
+ "
SRC_URI += " \
file://config-bmc.json \
@@ -19,12 +22,14 @@ SRC_URI += " \
file://inplace-gbmc-verify.sh \
file://inplace-gbmc-version.service \
file://inplace-gbmc-version.sh \
+ file://75-inplace-gbmc-upgrade.sh \
"
SYSTEMD_SERVICE:${PN} += "inplace-gbmc-verify.service"
SYSTEMD_SERVICE:${PN} += "inplace-gbmc-version.service"
FILES:${PN} += "${datadir}/phosphor-ipmi-flash"
+FILES:${PN} += "${datadir}/gbmc-br-dhcp"
do_install() {
sed -i 's,@ALLOW_DEV@,,' ${WORKDIR}/inplace-gbmc-verify.sh
@@ -37,6 +42,9 @@ do_install() {
install -d ${D}${datadir}/phosphor-ipmi-flash
install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
+
+ install -d ${D}${datadir}/gbmc-br-dhcp
+ install -m 0644 ${WORKDIR}/75-inplace-gbmc-upgrade.sh ${D}${datadir}/gbmc-br-dhcp/
}
do_install:prepend:dev() {