summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor
diff options
context:
space:
mode:
authorJie Yang <jjy@google.com>2021-08-06 22:41:16 +0300
committerJie Yang <jjy@google.com>2021-08-07 02:00:18 +0300
commit7fe1bad26b8f416f479c43068308167e4a267d10 (patch)
tree87ffda0c858eabbfc43ec832149a6da7f52dc335 /meta-google/recipes-phosphor
parent4dd03cae7a0a4afe12b172d404d9587da6971925 (diff)
downloadopenbmc-7fe1bad26b8f416f479c43068308167e4a267d10.tar.xz
meta-google: Add glome serial console login recipe
Signed-off-by: Jie Yang <jjy@google.com> Change-Id: I98f40cbbb412028330201d174e9624410529d1f6
Diffstat (limited to 'meta-google/recipes-phosphor')
-rw-r--r--meta-google/recipes-phosphor/console/glome_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-google/recipes-phosphor/console/glome_git.bb b/meta-google/recipes-phosphor/console/glome_git.bb
new file mode 100644
index 000000000..4750de8be
--- /dev/null
+++ b/meta-google/recipes-phosphor/console/glome_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "GLOME Login Client"
+DESCRIPTION = "GLOME login is first application of the GLOME protocol. It is used to authorize serial console access to Linux machines"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit meson pkgconfig
+
+DEPENDS += " \
+ openssl \
+ glib-2.0 \
+ "
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/google/glome.git"
+SRCREV = "b7084b5c60682a0b4f4ae3f2ec6048e65212c377"
+
+FILES_${PN} += "${libdir}/security"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
+PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
+
+EXTRA_OEMESON = "-Dtests=disabled"