summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-05-13 21:19:25 +0300
committerWilliam A. Kennington III <wak@google.com>2021-05-13 22:42:49 +0300
commit67f5063d272576de574ba9210c8c42f0d094fbf8 (patch)
tree7aaebde038a9e89b3b1fca3d2b08bc782979d570 /meta-google
parent8e2f55de9148065559a27268ce07d79009b9892a (diff)
downloadopenbmc-67f5063d272576de574ba9210c8c42f0d094fbf8.tar.xz
meta-google: gbmc-bridge: Fix do_rm_work
The workdir will be empty if the package is populated from the sstate, fix the command to work for this case. Change-Id: Ie262a69de067e94e9da32ca8a89d1db1a5ab5bf2 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-bridge.bb b/meta-google/recipes-google/networking/gbmc-bridge.bb
index bacb34958..37af84baf 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge.bb
+++ b/meta-google/recipes-google/networking/gbmc-bridge.bb
@@ -101,6 +101,5 @@ do_install() {
do_rm_work_prepend() {
# HACK: Work around broken do_rm_work not properly calling rm with `--`
# It doesn't like filenames that start with `-`
- mkdir -p ${WORKDIR}/done
- mv -- ${WORKDIR}/-* ${WORKDIR}/done
+ rm -rf -- ${WORKDIR}/-*
}