summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2021-10-02 02:56:41 +0300
committerWilly Tu <wltu@google.com>2021-10-02 03:32:30 +0300
commita971dac04754ba3ddf6f6c20a0fc2ecfe46127de (patch)
tree08773bbf823d9a602c3118583d03cd21944546ff /meta-google
parent52c0b9d7526653eaff38dcd23371eebb5ce5171d (diff)
downloadopenbmc-a971dac04754ba3ddf6f6c20a0fc2ecfe46127de.tar.xz
meta-google: os-release: Add dev/prod image type
Add dev/prod image type to /etc/os-release. Tested: Built with GBMC_CONFIG=dev bitbake obmc-phosphor-image ``` cat /etc/os-release ID=gbmc NAME="gBMC (OpenBMC + Google customizations)" VERSION="gbmc-release" VERSION_ID=gbmc-release-0.5.0.0 PRETTY_NAME="gBMC (OpenBMC + Google customizations) gbmc-release" BUILD_ID="2.11.0-dev" IMAGE_TYPE="dev" ``` Change-Id: I355e6069b08107717fb406b6b603ce4ce5264ff3 Signed-off-by: Willy Tu <wltu@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-core/os-release/os-release.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-google/recipes-core/os-release/os-release.bbappend b/meta-google/recipes-core/os-release/os-release.bbappend
index 8c61bbccf..f6b7cc152 100644
--- a/meta-google/recipes-core/os-release/os-release.bbappend
+++ b/meta-google/recipes-core/os-release/os-release.bbappend
@@ -7,4 +7,5 @@ python() {
d.setVar("BUILD_MEMO", memo)
}
-OS_RELEASE_FIELDS:append = " BUILD_MEMO"
+IMAGE_TYPE = "${GBMC_CONFIG}"
+OS_RELEASE_FIELDS:append = " BUILD_MEMO IMAGE_TYPE"