summaryrefslogtreecommitdiff
path: root/meta-hpe/conf
diff options
context:
space:
mode:
authorJorge Cisneros <jorge.cisneros@hpe.com>2020-09-04 00:09:03 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-09-09 16:49:10 +0300
commit8a445a08318f2c25be409851d9bb6a491d923953 (patch)
treefb27b0e6ae23f656ff33de9974a81b9aa024174d /meta-hpe/conf
parent4d14968af13ba43fb00d0a89a1ff4e18a8d25c69 (diff)
downloadopenbmc-8a445a08318f2c25be409851d9bb6a491d923953.tar.xz
Added new layers and new conf dl360poc
(From meta-hpe rev: 32ae68cd72e95760e004fa6443278e4e703535c0) Signed-off-by: Jorge Cisneros <jorge.cisneros@hpe.com> Change-Id: I611c734ab19f6a5a3bded6b8979791560ced082d Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-hpe/conf')
-rw-r--r--meta-hpe/conf/layer.conf13
-rw-r--r--meta-hpe/conf/machine/include/hpe.inc19
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-hpe/conf/layer.conf b/meta-hpe/conf/layer.conf
new file mode 100644
index 000000000..3d2fce1f3
--- /dev/null
+++ b/meta-hpe/conf/layer.conf
@@ -0,0 +1,13 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
+ ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "hpe-layer"
+BBFILE_PATTERN_hpe-layer := "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_hpe-layer = "zeus warrior dunfell"
+
+# Provide a variable that points the base of the hpe layer.
+HPEBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-hpe/conf/machine/include/hpe.inc b/meta-hpe/conf/machine/include/hpe.inc
new file mode 100644
index 000000000..1e928beeb
--- /dev/null
+++ b/meta-hpe/conf/machine/include/hpe.inc
@@ -0,0 +1,19 @@
+OBMC_MACHINE_FEATURES += "\
+ obmc-phosphor-fan-mgmt \
+ obmc-phosphor-chassis-mgmt \
+ obmc-phosphor-flash-mgmt \
+ obmc-host-ipmi \
+ obmc-host-state-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-bmc-state-mgmt \
+ "
+
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-hpe-apps"
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-hpe-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-hpe-apps"
+PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-hpe-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= ""
+#PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-hostfw-config ?= "hostboot-inventory-config-native"
+
+IMAGE_FEATURES_remove = "obmc-fan-control"