summaryrefslogtreecommitdiff
path: root/meta-hpe/meta-dl360poc/recipes-phosphor
diff options
context:
space:
mode:
authorJorge Cisneros <jorge.cisneros@hpe.com>2020-09-04 00:09:03 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-09-09 16:49:10 +0300
commit8a445a08318f2c25be409851d9bb6a491d923953 (patch)
treefb27b0e6ae23f656ff33de9974a81b9aa024174d /meta-hpe/meta-dl360poc/recipes-phosphor
parent4d14968af13ba43fb00d0a89a1ff4e18a8d25c69 (diff)
downloadopenbmc-8a445a08318f2c25be409851d9bb6a491d923953.tar.xz
Added new layers and new conf dl360poc
(From meta-hpe rev: 32ae68cd72e95760e004fa6443278e4e703535c0) Signed-off-by: Jorge Cisneros <jorge.cisneros@hpe.com> Change-Id: I611c734ab19f6a5a3bded6b8979791560ced082d Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-hpe/meta-dl360poc/recipes-phosphor')
-rw-r--r--meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend b/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend
new file mode 100644
index 000000000..ad672452a
--- /dev/null
+++ b/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend
@@ -0,0 +1,23 @@
+
+
+do_generate_hpe_image() {
+ # Add gxp-bootblock to hpe-section
+ dd bs=1k conv=notrunc seek=64 \
+ if=${DEPLOY_DIR_IMAGE}/${HPE_GXP_BOOTBLOCK_IMAGE} \
+ of=${DEPLOY_DIR_IMAGE}/hpe-section
+}
+
+do_generate_static_tar() {
+
+ ln -sf ${S}/MANIFEST MANIFEST
+ ln -sf ${S}/publickey publickey
+ make_image_links ${OVERLAY_BASETYPE} ${IMAGE_BASETYPE}
+
+ make_signatures image-u-boot image-kernel image-rofs image-rwfs image-section MANIFEST publickey
+ make_tar_of_images static MANIFEST publickey ${signature_files}
+
+ # Maintain non-standard legacy link.
+ cd ${IMGDEPLOYDIR}
+ ln -sf ${IMAGE_NAME}.static.mtd.tar ${IMGDEPLOYDIR}/${MACHINE}-${DATETIME}.tar
+}
+