summaryrefslogtreecommitdiff
path: root/meta-hpe
diff options
context:
space:
mode:
authorMike Garrett <mike.garrett@hpe.com>2021-08-27 23:51:09 +0300
committerMike Garrett <mike.garrett@hpe.com>2021-08-31 03:34:22 +0300
commit4eb108b1dce1423ff39cfd4ac23556da58554376 (patch)
tree1ce779368ac72894555184dae2b9e4b9e4dc1ae2 /meta-hpe
parent57272ae3079bd1882ad952283e649fd51a2b91f5 (diff)
downloadopenbmc-4eb108b1dce1423ff39cfd4ac23556da58554376.tar.xz
meta-hpe: Update binary bootblock recipes for GXP
Update the build recipes for the GXP binary bootblock that runs before U-Boot. The code has been restructured such that the DL360POC machine is the exception, so this includes the overrides for the DL360POC. Signed-off-by: Mike Garrett <mike.garrett@hpe.com> Change-Id: I507a6e32c7c72613dbd1239824f528f0f60d1f6f
Diffstat (limited to 'meta-hpe')
-rw-r--r--meta-hpe/meta-dl360poc/recipes-bsp/image/gxp-bootblock.bb1
-rw-r--r--meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass5
-rw-r--r--meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass26
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/image/files/header-512.sigbin0 -> 20 bytes
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/image/files/header.sigbin0 -> 20 bytes
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb2
6 files changed, 30 insertions, 4 deletions
diff --git a/meta-hpe/meta-dl360poc/recipes-bsp/image/gxp-bootblock.bb b/meta-hpe/meta-dl360poc/recipes-bsp/image/gxp-bootblock.bb
new file mode 100644
index 000000000..969937551
--- /dev/null
+++ b/meta-hpe/meta-dl360poc/recipes-bsp/image/gxp-bootblock.bb
@@ -0,0 +1 @@
+inherit gxp-bootblock-n-poc
diff --git a/meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass b/meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass
index 206203055..fb3570104 100644
--- a/meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass
+++ b/meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass
@@ -4,15 +4,14 @@ LIC_FILES_CHKSUM = ""
BBRANCH = "master"
SRC_URI = "git://github.com/HewlettPackard/gxp-bootblock.git;branch=${BBRANCH}"
-SRCREV = "1d4b424934ab3a2f22cf1b9a459a38e45971509f"
+SRCREV = "bab416f8ca8c8465d308cfeb7f8d5abc21ba343b"
S = "${WORKDIR}/git"
inherit deploy
do_deploy () {
install -d ${DEPLOYDIR}
-
- install -m 644 gxp-bootblock-dl360poc.bin ${DEPLOYDIR}/gxp-bootblock.bin
+ install -m 644 gxp-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin
}
diff --git a/meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass b/meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass
new file mode 100644
index 000000000..bd69e16a0
--- /dev/null
+++ b/meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass
@@ -0,0 +1,26 @@
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+# TODO: Manually copy the U-Boot signing key and customer-key-block here:
+HPE_GXP_KEY_FILES_DIR = "${COREBASE}/meta-hpe/meta-gxp/recipes-bsp/image/files"
+
+inherit deploy
+
+do_deploy () {
+ install -d ${DEPLOYDIR}
+
+ # Copy in the bootblock
+ install -m 644 ${HPE_GXP_KEY_FILES_DIR}/gxp-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin
+
+ # Copy in files from the files subdirectory
+ install -m 644 ${HPE_GXP_KEY_FILES_DIR}/header.sig ${DEPLOYDIR}/hpe-uboot-header.section
+
+ # Copy in the U-Boot signing key
+ install -m 644 ${HPE_GXP_KEY_FILES_DIR}/private_key.pem ${DEPLOYDIR}/hpe-uboot-signing-key.pem
+
+ # Copy in the customer keyblock
+ install -m 644 ${HPE_GXP_KEY_FILES_DIR}/customer-key-block ${DEPLOYDIR}/customer-key-block
+}
+
+addtask deploy before do_build after do_compile
+
diff --git a/meta-hpe/meta-gxp/recipes-bsp/image/files/header-512.sig b/meta-hpe/meta-gxp/recipes-bsp/image/files/header-512.sig
new file mode 100644
index 000000000..818bd6f74
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-bsp/image/files/header-512.sig
Binary files differ
diff --git a/meta-hpe/meta-gxp/recipes-bsp/image/files/header.sig b/meta-hpe/meta-gxp/recipes-bsp/image/files/header.sig
new file mode 100644
index 000000000..765375d02
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-bsp/image/files/header.sig
Binary files differ
diff --git a/meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb b/meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb
index 969937551..d8bcc5428 100644
--- a/meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb
+++ b/meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb
@@ -1 +1 @@
-inherit gxp-bootblock-n-poc
+inherit gxp-bootblock-n