summaryrefslogtreecommitdiff
path: root/meta-hpe
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-11-03 18:35:37 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-11-04 12:36:33 +0300
commit5a5f33c729e6b5869362172b63595422eb84a418 (patch)
treee59a7c80674d5e569507b4f0e317d1710408e654 /meta-hpe
parent552e93e6ec8d72befcbe7ea59c3a57968f6603dc (diff)
downloadopenbmc-5a5f33c729e6b5869362172b63595422eb84a418.tar.xz
Partially revert "treewide: remove obmc-system-mgmt feature"
The obmc-system-mgmt feature is currently used in the image to trigger inclusion of a virtual-provider which provides a number of packages many systems need. Partially revert the removal of this feature so that the outcome is: 1. The empty obmc-phosphor-sysd package is still removed. 2. By default the 'obmc-system-mgmt' feature is included, unless specifically exempted. 3. All EVB platforms remove the 'obmc-system-mgmt' feature since they have no system they are managing. This partially reverts commit 060ad3ff7fcc30aff78a9e504efee9d8fa0d4526. Tested: * Built `bletchley` and confirmed `packagegroup-fb-apps-system` and `entity-manager` are present. ``` entity-manager armv7ahf-vfpv4d16 0.1+git0+6bf41588ab-r0 packagegroup-fb-apps-system all 1.0-r1 ``` * Built `witherspoon` and confirmed `packagegroup-op-apps-system` and `pdbg` are present. ``` packagegroup-op-apps-system noarch 1.0 pdbg arm1176jzs 3.3 ``` * Ran `bitbake -p` on `evb-ast2600` to confirm the undefined `virtual-obmc-system-mgmt` is not being included in the image. Change-Id: I8b7804d5101cc84a2c57473b3f85672bf7767c67 Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-hpe')
-rw-r--r--meta-hpe/conf/machine/include/hpe.inc1
-rw-r--r--meta-hpe/meta-common/recipes-phosphor/packagegroups/packagegroup-hpe-apps.bb2
2 files changed, 3 insertions, 0 deletions
diff --git a/meta-hpe/conf/machine/include/hpe.inc b/meta-hpe/conf/machine/include/hpe.inc
index 79896c713..281d2d544 100644
--- a/meta-hpe/conf/machine/include/hpe.inc
+++ b/meta-hpe/conf/machine/include/hpe.inc
@@ -15,6 +15,7 @@ PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-hpe-apps"
PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-hpe-apps"
PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-hpe-apps"
+PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-hpe-apps"
PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= ""
#PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-hostfw-config ?= "hostboot-inventory-config-native"
diff --git a/meta-hpe/meta-common/recipes-phosphor/packagegroups/packagegroup-hpe-apps.bb b/meta-hpe/meta-common/recipes-phosphor/packagegroups/packagegroup-hpe-apps.bb
index 9fdcd4b2e..3f16d41e7 100644
--- a/meta-hpe/meta-common/recipes-phosphor/packagegroups/packagegroup-hpe-apps.bb
+++ b/meta-hpe/meta-common/recipes-phosphor/packagegroups/packagegroup-hpe-apps.bb
@@ -14,10 +14,12 @@ PACKAGES = " \
PROVIDES += "virtual/obmc-chassis-mgmt"
PROVIDES += "virtual/obmc-fan-mgmt"
PROVIDES += "virtual/obmc-flash-mgmt"
+PROVIDES += "virtual/obmc-system-mgmt"
RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
RPROVIDES:${PN}-fans += "virtual-obmc-fan-mgmt"
RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
SUMMARY:${PN}-chassis = "HPE Chassis"
RDEPENDS:${PN}-chassis = " \