summaryrefslogtreecommitdiff
path: root/meta-hpe
diff options
context:
space:
mode:
authorMike Garrett <mike.garrett@hpe.com>2021-08-28 00:50:20 +0300
committerMike Garrett <mike.garrett@hpe.com>2021-09-07 21:33:00 +0300
commit6d539b96c484e8dbaeae9170e9bb1c052270433e (patch)
tree2cd92b99bcfcdbfa349bfb11cd5bd8f1cfa2bf56 /meta-hpe
parent02b54b36f0be0f8dc3aa06b3a83e88feb63c1768 (diff)
downloadopenbmc-6d539b96c484e8dbaeae9170e9bb1c052270433e.tar.xz
meta-hpe: Update Linux kernel to 5.10 from 5.7
Linux kernel and DTS updates Signed-off-by: Mike Garrett <mike.garrett@hpe.com> Change-Id: I365e1b6d1d060c131c9d7a1b0f76ef9256f0e73f
Diffstat (limited to 'meta-hpe')
-rw-r--r--meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts256
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc1
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig35
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb10
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.7.bb9
5 files changed, 162 insertions, 149 deletions
diff --git a/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts b/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts
index c11ccb023..92f933b50 100644
--- a/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts
+++ b/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts
@@ -44,7 +44,7 @@
interrupt-parent = <&vic0>;
clock-frequency = <400000000>;
};
-
+
watchdog: watchdog@c0000090 {
compatible = "hpe,gxp-wdt";
reg = <0xc0000090 0x02>, <0xc0000096 0x01>;
@@ -82,7 +82,7 @@
reg = <0x80fc0230 0x100>;
reg-io-width = <1>;
};
-
+
vuart_a: vuart_a@80fd0200 {
compatible = "hpe,gxp-vuart";
reg = <0x80fd0200 0x100>;
@@ -94,7 +94,21 @@
serial-line = <3>;
vuart_cfg = <&vuart_a_cfg>;
};
-
+
+ usb0: ehci@cefe0000 {
+ compatible = "generic-ehci";
+ reg = <0xcefe0000 0x100>;
+ interrupts = <7>;
+ interrupt-parent = <&vic0>;
+ };
+
+ usb1: ohci@cefe0100 {
+ compatible = "generic-ohci";
+ reg = <0xcefe0100 0x110>;
+ interrupts = <6>;
+ interrupt-parent = <&vic0>;
+ };
+
spifi0: spifi@c0000200 {
compatible = "hpe,gxp-spifi";
reg = <0xc0000200 0x80>, <0xc000c000 0x100>, <0xf8000000 0x8000000>;
@@ -110,7 +124,11 @@
compatible = "fixed-partitions";
#address-cells = <1>;
#size-cells = <1>;
-
+
+ bmc@0 {
+ label = "bmc";
+ reg = <0x0 0x2000000>;
+ };
u-boot@0 {
label = "u-boot";
reg = <0x0 0x60000>;
@@ -132,7 +150,7 @@
reg = <0x1c80000 0x250000>;
};
section@1edf000{
- labele = "section";
+ label = "section";
reg = <0x1ed0000 0x130000>;
};
};
@@ -197,7 +215,7 @@
compatible = "syscon";
reg = <0xc00000f8 0x08>;
};
-
+
i2c0: i2c@c0002000 {
compatible = "hpe,gxp-i2c";
reg = <0xc0002000 0x70>;
@@ -227,8 +245,8 @@
#address-cells = <1>;
#size-cells = <0>;
- at24c02@50 {
- compatible = "at24,24c02";
+ 24c02@50 {
+ compatible = "atmel,24c02";
pagesize = <8>;
reg = <0x50>;
};
@@ -260,18 +278,6 @@
interrupts = <9>;
interrupt-parent = <&vic0>;
i2cg-handle = <&i2cg>;
- #address-cells = <1>;
- #size-cells = <0>;
-
- emc1402@4c {
- compatible = "emc1402";
- reg = <0x4c>;
- };
-
- emc1404@1c {
- compatible = "emc1404";
- reg = <0x1c>;
- };
};
i2c6: i2c@c0002600 {
@@ -441,7 +447,7 @@
compatible = "hpe,gxp-kcs-bmc-cfg", "simple-mfd", "syscon";
reg = <0x80fc0430 0x100>;
};
-
+
kcs_reg: kcs_reg@080fd0400 {
compatible = "hpe,gxp-kcs-bmc";
reg = <0x80fd0400 0x8>;
@@ -460,9 +466,23 @@
height = <600>;
};
- xreg: xreg@d1000000 {
+ xreg: xreg@d1000300 {
compatible = "hpe,gxp-xreg", "simple-mfd", "syscon";
reg = <0xd1000300 0xFF>;
+ interrupts = <26>;
+ interrupt-parent = <&vic0>;
+ #gpio-cells = <2>;
+ gpio-line-names =
+ "", "", "", "", "", "", "POWER", "HEARTBEAT", "FAN1_INST", "FAN2_INST",
+ "FAN3_INST", "FAN4_INST", "FAN5_INST", "FAN6_INST", "FAN7_INST", "FAN8_INST", "FAN9_INST", "FAN10_INST", "FAN11_INST", "FAN12_INST",
+ "FAN13_INST", "FAN14_INST", "FAN15_INST", "FAN16_INST", "FAN1_FAIL", "FAN2_FAIL", "FAN3_FAIL", "FAN4_FAIL", "FAN5_FAIL", "FAN6_FAIL",
+ "FAN7_FAIL", "FAN8_FAIL", "FAN9_FAIL", "FAN10_FAIL", "FAN11_FAIL", "FAN12_FAIL", "FAN13_FAIL", "FAN14_FAIL", "FAN15_FAIL", "FAN16_FAIL",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "IDENTIFY", "HEALTH_RED", "HEALTH_AMBER", "POWER_BUTTON",
+ "", "SIO_POWER_GOOD", "NMI_BUTTON", "RESET_BUTTON", "SIO_S5", "SIO_ONCONTROL", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "";
};
fanctrl: fanctrl@c1000c00 {
@@ -475,154 +495,107 @@
fn2: fn2@80200000 {
compatible = "hpe,gxp-fn2", "simple-mfd", "syscon";
reg = <0x80200000 0x100000>;
+ xreg_handle = <&xreg>;
interrupts = <0>;
interrupt-parent = <&vic1>;
+ #gpio-cells = <2>;
+ gpio-line-names =
+ "POWER_OUT", "PS_PWROK", "PCIERST", "POST_COMPLETE", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "";
+ chif {
+ compatible = "hpe,gxp-chif";
+ interrupts = <12>;
+ };
};
csm: csm@80000000 {
compatible = "hpe,gxp-csm", "simple-mfd", "syscon";
- reg = <0x80000000 0x100000>;
+ reg = <0x80000000 0x400>;
};
- gpio: gpio {
+ gpio: gpio@0 {
compatible = "hpe,gxp-gpio";
#gpio-cells = <2>;
csm_handle = <&csm>;
- fn2_handle = <&fn2>;
- xreg_handle = <&xreg>;
vuhc0_handle = <&vuhc0>;
- interrupts = <26>;
- interrupt-parent = <&vic0>;
+ gpio-line-names =
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "RESET_OUT", "NMI_OUT", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "";
};
leds: leds {
compatible = "gpio-leds";
power {
- gpios = <&gpio 306 0>;
+ gpios = <&xreg 6 0>;
default-state = "off";
};
heartbeat {
- gpios = <&gpio 307 0>;
+ gpios = <&xreg 7 0>;
default-state = "off";
};
identify {
- gpios = <&gpio 356 0>;
+ gpios = <&xreg 56 0>;
default-state = "off";
};
health_red {
- gpios = <&gpio 357 0>;
+ gpios = <&xreg 57 0>;
default-state = "off";
};
health_amber {
- gpios = <&gpio 358 0>;
+ gpios = <&xreg 58 0>;
default-state = "off";
};
};
- presence: presence {
+ xreg_kyes: xreg_keys {
compatible = "gpio-keys-polled";
poll-interval = <100>;
- autorepeat;
- fan1 {
- label = "fan1 presence";
+ IdButton {
+ label = "ID Button";
linux,code = <200>;
- gpios = <&gpio 308 0>;
- };
-
- fan2 {
- label = "fan2 presence";
- linux,code = <201>;
- gpios = <&gpio 309 0>;
- };
-
- fan3 {
- label = "fan3 presence";
- linux,code = <202>;
- gpios = <&gpio 310 0>;
- };
-
- fan4 {
- label = "fan4 presence";
- linux,code = <203>;
- gpios = <&gpio 311 0>;
- };
-
- fan5 {
- label = "fan5 presence";
- linux,code = <204>;
- gpios = <&gpio 312 0>;
- };
-
- fan6 {
- label = "fan6 presence";
- linux,code = <205>;
- gpios = <&gpio 313 0>;
- };
-
- fan7 {
- label = "fan7 presence";
- linux,code = <206>;
- gpios = <&gpio 314 0>;
- };
-
- fan8 {
- label = "fan8 presence";
- linux,code = <207>;
- gpios = <&gpio 315 0>;
- };
-
- fan9 {
- label = "fan9 presence";
- linux,code = <208>;
- gpios = <&gpio 316 0>;
- };
-
- fan10 {
- label = "fan10 presence";
- linux,code = <209>;
- gpios = <&gpio 317 0>;
- };
-
- fan11 {
- label = "fan11 presence";
- linux,code = <210>;
- gpios = <&gpio 318 0>;
- };
-
- fan12 {
- label = "fan12 presence";
- linux,code = <211>;
- gpios = <&gpio 319 0>;
- };
-
- fan13 {
- label = "fan13 presence";
- linux,code = <212>;
- gpios = <&gpio 320 0>;
- };
-
- fan14 {
- label = "fan14 presence";
- linux,code = <213>;
- gpios = <&gpio 321 0>;
- };
-
- fan15 {
- label = "fan15 presence";
- linux,code = <214>;
- gpios = <&gpio 322 0>;
- };
-
- fan16 {
- label = "fan16 presence";
- linux,code = <215>;
- gpios = <&gpio 323 0>;
+ gpios = <&xreg 60 1>;
};
};
@@ -641,6 +614,12 @@
linux,code = <201>;
gpios = <&gpio 251 1>;
};
+
+ PortOwner@2 {
+ label = "Port Owner";
+ linux,code = <202>;
+ gpios = <&gpio 252 1>;
+ };
};
vuhc0: vuhc@80400080 {
@@ -659,7 +638,7 @@
interrupts = <13>;
interrupt-parent = <&vic1>;
vdevnum = <0>;
- fepnum = <7>;
+ fepnum = <4>;
udcg-handle = <&udcg>;
};
@@ -669,7 +648,17 @@
interrupts = <13>;
interrupt-parent = <&vic1>;
vdevnum = <1>;
- fepnum = <7>;
+ fepnum = <4>;
+ udcg-handle = <&udcg>;
+ };
+
+ udc2: udc@80403000 {
+ compatible = "hpe, gxp-udc";
+ reg = <0x80403000 0x1000>;
+ interrupts = <13>;
+ interrupt-parent = <&vic1>;
+ vdevnum = <2>;
+ fepnum = <4>;
udcg-handle = <&udcg>;
};
@@ -682,6 +671,13 @@
compatible = "hpe,gxp-power";
psu_phandle = <&psu1>, <&psu2>;
};
+
+ peci: peci@80000400 {
+ compatible = "hpe,gxp-peci";
+ reg = <0x80000400 0x200>;
+ interrupts = <22>;
+ interrupt-parent = <&vic1>;
+ };
};
clocks {
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
index 5c172b1c4..5d79797f7 100644
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
@@ -21,3 +21,4 @@ require recipes-kernel/linux/linux-yocto.inc
# From 4.16+ the COPYING file changed
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig
index 1507daf83..cdd03e3f7 100644
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig
@@ -26,8 +26,6 @@ CONFIG_ARCH_HPE=y
CONFIG_ARCH_HPE_GXP=y
CONFIG_SECCOMP=y
# CONFIG_ATAGS is not set
-CONFIG_ZBOOT_ROM_TEXT=0x0
-CONFIG_ZBOOT_ROM_BSS=0x0
# CONFIG_SUSPEND is not set
CONFIG_ARM_CRYPTO=y
CONFIG_CRYPTO_SHA1_ARM=y
@@ -37,8 +35,6 @@ CONFIG_CRYPTO_AES_ARM=y
CONFIG_CRYPTO_CHACHA20_NEON=y
CONFIG_CRYPTO_POLY1305_ARM=y
CONFIG_JUMP_LABEL=y
-# CONFIG_STRICT_KERNEL_RWX is not set
-# CONFIG_BLK_DEBUG_FS is not set
# CONFIG_CORE_DUMP_DEFAULT_ELF_HEADERS is not set
CONFIG_KSM=y
CONFIG_CLEANCACHE=y
@@ -50,12 +46,22 @@ CONFIG_UNIX_DIAG=y
CONFIG_XFRM_USER=y
CONFIG_XFRM_STATISTICS=y
CONFIG_INET=y
+CONFIG_IP_ADVANCED_ROUTER=y
+CONFIG_IP_MULTIPLE_TABLES=y
+CONFIG_IP_ROUTE_MULTIPATH=y
+CONFIG_IP_ROUTE_VERBOSE=y
+CONFIG_IP_PNP=y
+CONFIG_IP_PNP_DHCP=y
+CONFIG_IP_PNP_BOOTP=y
CONFIG_IPV6_ROUTER_PREF=y
CONFIG_IPV6_ROUTE_INFO=y
+CONFIG_IPV6_OPTIMISTIC_DAD=y
# CONFIG_IPV6_SIT is not set
+CONFIG_IPV6_MULTIPLE_TABLES=y
CONFIG_BPFILTER=y
CONFIG_VLAN_8021Q=y
CONFIG_NETLINK_DIAG=y
+CONFIG_NET_NCSI=y
# CONFIG_WIRELESS is not set
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y
@@ -114,7 +120,7 @@ CONFIG_NETDEVICES=y
# CONFIG_NET_VENDOR_VIA is not set
# CONFIG_NET_VENDOR_WIZNET is not set
# CONFIG_NET_VENDOR_XILINX is not set
-CONFIG_UMAC=y
+CONFIG_GXP_UMAC=y
# CONFIG_USB_NET_DRIVERS is not set
# CONFIG_WLAN is not set
# CONFIG_INPUT_LEDS is not set
@@ -140,16 +146,20 @@ CONFIG_IPMI_DEVICE_INTERFACE=y
CONFIG_IPMI_SI=y
CONFIG_IPMI_SSIF=y
CONFIG_HPE_KCS_IPMI_BMC=y
+CONFIG_IPMB_DEVICE_INTERFACE=y
CONFIG_HW_RANDOM_TIMERIOMEM=y
CONFIG_I2C_CHARDEV=y
CONFIG_I2C_GXP=y
CONFIG_I2C_SLAVE=y
CONFIG_I2C_SLAVE_EEPROM=y
-CONFIG_I2C_SLAVE_MQUEUE=y
CONFIG_SPI=y
CONFIG_GPIOLIB=y
CONFIG_GPIO_SYSFS=y
+CONFIG_GPIO_GXP_XREG=y
CONFIG_GPIO_GXP=y
+CONFIG_SENSORS_PECI_CPUTEMP=y
+CONFIG_SENSORS_PECI_DIMMTEMP=y
+CONFIG_SENSORS_SBTSI=y
CONFIG_SENSORS_EMC1403=y
CONFIG_SENSORS_GXP_FAN_CTRL=y
CONFIG_SENSORS_GXP_CORETEMP=y
@@ -205,12 +215,17 @@ CONFIG_HPE_GXP_XREG=y
CONFIG_HPE_GXP_FN2=y
CONFIG_HPE_GXP_CSM=y
CONFIG_HPE_GXP_SROM=y
+CONFIG_HPE_GXP_CHIF=y
CONFIG_PECI=y
CONFIG_PECI_CHARDEV=y
+CONFIG_PECI_GXP=y
CONFIG_FANOTIFY=y
CONFIG_AUTOFS_FS=y
CONFIG_OVERLAY_FS=y
CONFIG_OVERLAY_FS_REDIRECT_DIR=y
+CONFIG_VFAT_FS=y
+CONFIG_FAT_DEFAULT_UTF8=y
+CONFIG_EXFAT_FS=y
CONFIG_TMPFS=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_JFFS2_FS=y
@@ -235,6 +250,7 @@ CONFIG_CRYPTO_ARC4=y
CONFIG_CRYPTO_DEFLATE=y
CONFIG_CRYPTO_LZO=y
CONFIG_CRYPTO_ZSTD=y
+CONFIG_CRYPTO_ANSI_CPRNG=y
CONFIG_CRYPTO_USER_API_HASH=y
# CONFIG_CRYPTO_HW is not set
CONFIG_CRC16=y
@@ -249,10 +265,9 @@ CONFIG_DEBUG_INFO=y
# CONFIG_ENABLE_MUST_CHECK is not set
CONFIG_MAGIC_SYSRQ=y
CONFIG_PANIC_ON_OOPS=y
-CONFIG_SCHED_TRACER=y
-CONFIG_STACK_TRACER=y
CONFIG_FUNCTION_PROFILER=y
-CONFIG_TEST_KSTRTOX=y
+CONFIG_STACK_TRACER=y
+CONFIG_SCHED_TRACER=y
CONFIG_STRICT_DEVMEM=y
CONFIG_DEBUG_USER=y
CONFIG_DEBUG_LL=y
@@ -261,4 +276,4 @@ CONFIG_DEBUG_UART_PHYS=0xC00000F0
CONFIG_DEBUG_UART_VIRT=0xF00000F0
CONFIG_DEBUG_UART_8250_SHIFT=0
CONFIG_EARLY_PRINTK=y
-CONFIG_UNWINDER_FRAME_POINTER=y
+CONFIG_TEST_KSTRTOX=y
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb
new file mode 100644
index 000000000..d0b5407ae
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb
@@ -0,0 +1,10 @@
+KBRANCH ?= "dev-5.10-gxp-openbmc"
+LINUX_VERSION ?= "5.10.17"
+SRCREV="8d942b456304d3a21597cda47387a45ace61a225"
+
+require linux-obmc.inc
+require conf/machine/include/fitimage-sign.inc
+
+# OpenBMC loads in kernel features via other mechanisms so this check
+# in the kernel-yocto.bbclass is not required
+#KERNEL_DANGLING_FEATURES_WARN_ONLY="1"
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.7.bb b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.7.bb
deleted file mode 100644
index 0e57afd87..000000000
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.7.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-KBRANCH ?= "dev-5.7-gxp-openbmc"
-LINUX_VERSION ?= "5.7.10"
-
-SRCREV="1ca49db2b4baf304d29396a603d0308770797a5c"
-require linux-obmc.inc
-
-# OpenBMC loads in kernel features via other mechanisms so this check
-# in the kernel-yocto.bbclass is not required
-KERNEL_DANGLING_FEATURES_WARN_ONLY="1"