summaryrefslogtreecommitdiff
path: root/meta-hpe
diff options
context:
space:
mode:
authorAnton Blanchard <anton@ozlabs.org>2021-08-17 08:51:27 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-17 17:51:56 +0300
commit782d7195eac9bb9e05f86477b9537dbbee26930c (patch)
tree459a1d60da8a54ccc7eec4c5dd8b5e8a6c664bb7 /meta-hpe
parent3f248dc32aa8c8f9c294d955fe0f19d8c8c4579a (diff)
downloadopenbmc-782d7195eac9bb9e05f86477b9537dbbee26930c.tar.xz
Fix path to udev rules files
Use nonarch_base_libdir instead of base_libdir, because the files are always in /lib/udev/rules.d/. On ppc64le base_libdir is lib64, and the files end up in the wrong spot. Signed-off-by: Anton Blanchard <anton@ozlabs.org> Change-Id: I3c24dae293f4166f1ed1826d09d4bde7cd7d0357
Diffstat (limited to 'meta-hpe')
-rw-r--r--meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb b/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb
index dc185655b..9954b6397 100644
--- a/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb
+++ b/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb
@@ -10,6 +10,6 @@ SRC_URI += "file://76-gxp-mtd-partitions.rules"
RDEPENDS_${PN} += "udev"
do_install() {
- install -d ${D}/${base_libdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/76-gxp-mtd-partitions.rules ${D}/${base_libdir}/udev/rules.d
+ install -d ${D}/${nonarch_base_libdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/76-gxp-mtd-partitions.rules ${D}/${nonarch_base_libdir}/udev/rules.d
}