summaryrefslogtreecommitdiff
path: root/meta-hpe
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-10-15 05:28:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-10-15 20:46:44 +0300
commitd44abb3862c91a7181b6ff47af337825d36f24e4 (patch)
tree50555019808d170f5c5453c8e6440c95f6a6a06d /meta-hpe
parent6610b2e387113ae131eb837680fe2478b863f8b2 (diff)
downloadopenbmc-d44abb3862c91a7181b6ff47af337825d36f24e4.tar.xz
meta-phosphor: image: update ConfigParser class name
As a follow up to 400d9dab03e25d992429f94296caa4938c281fbd, fix the deprecated SafeConfigParser to ConfigParser across the tree. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Iabf941889eed97a996b739d77c8107f1f35ce5bf
Diffstat (limited to 'meta-hpe')
-rw-r--r--meta-hpe/meta-common/recipes-phosphor/image/obmc-phosphor-image.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-hpe/meta-common/recipes-phosphor/image/obmc-phosphor-image.bbappend b/meta-hpe/meta-common/recipes-phosphor/image/obmc-phosphor-image.bbappend
index 721ad10ad..5cc1192f9 100644
--- a/meta-hpe/meta-common/recipes-phosphor/image/obmc-phosphor-image.bbappend
+++ b/meta-hpe/meta-common/recipes-phosphor/image/obmc-phosphor-image.bbappend
@@ -10,7 +10,7 @@ def do_get_version(d):
import io
path = d.getVar('STAGING_DIR_TARGET', True) + d.getVar('sysconfdir', True)
path = os.path.join(path, 'os-release')
- parser = configparser.SafeConfigParser(strict=False)
+ parser = configparser.ConfigParser(strict=False)
parser.optionxform = str
version = ''
try: