summaryrefslogtreecommitdiff
path: root/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb
diff options
context:
space:
mode:
authorYuan Yao <yao.yuan@hxt-semitech.com>2018-12-07 13:09:48 +0300
committerAndrew Geissler <geissonator@yahoo.com>2019-03-12 16:13:57 +0300
commitc13f46e1deabb6ba19e818ce5050ccfbebc6d070 (patch)
treeb24ad904b26e8a99c3b2e101835e960c4a039cb1 /meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb
parent70750e3076dada93f9e4279408aa24ee8fdf62a6 (diff)
downloadopenbmc-c13f46e1deabb6ba19e818ce5050ccfbebc6d070.tar.xz
meta-hxt: add soc update script
Add a simple script to help update the soc(host) firmware by flashcp. Usage: Format: socupdate.sh FileName IP Example: socupdate.sh 0ACJAXXX.ROM 192.168.1.1 (From meta-hxt rev: 5679e42877a21303207011a2f8ec3e643b5e76b2) Change-Id: I44da894bdbe048c7a79ec30bedd006918e1ae2d2 Signed-off-by: Yuan Yao <yao.yuan@hxt-semitech.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb')
-rw-r--r--meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb
new file mode 100644
index 000000000..e2ae60afb
--- /dev/null
+++ b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb
@@ -0,0 +1,13 @@
+SUMMARY = "HXT SOC update"
+DESCRIPTION = "A sample script to help update the host(soc) firmware"
+HOMEPAGE = ""
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${HXTBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI += "file://socupdate.sh"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/socupdate.sh ${D}${bindir}/socupdate.sh
+}