summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2020-01-14 12:17:01 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-14 19:49:28 +0300
commit5572be3b99099bcbc7965ca692faf885a88a665f (patch)
tree3c57feffa4cf2e50f419ce486f2b304cf5a50b4a /meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb
parent6c3517c6fbb4a2ff4dda78ad7236b14421200a81 (diff)
downloadopenbmc-5572be3b99099bcbc7965ca692faf885a88a665f.tar.xz
meta-romulus: Add inventory-cleanup.yaml
The yaml add the "xyz.openbmc_project.Inventory.Item.Chassis" interface to "/xyz/openbmc_project/inventory/system/chassis" object. This is needed for bmcweb to correctly get the chassis id in /redfish/v1/Chassis/. Tested: Verify that /redfish/v1/Chassis/chassis exists on Romulus with this change. It was 404 without this change. (From meta-ibm rev: 41b829feead473e5541f7d4c3c075e2b1a525c45) Signed-off-by: Lei YU <mine260309@gmail.com> Change-Id: Ie091ad32315fb4b4e45d8b35966a7a238dd1d539 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb')
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb
new file mode 100644
index 000000000..0c4b56f72
--- /dev/null
+++ b/meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+S = "${WORKDIR}"
+
+SRC_URI = "file://inventory-cleanup.yaml"
+
+do_install() {
+ install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
+}
+
+FILES_${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"