summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-romulus
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-04-04 23:06:43 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-06 01:37:29 +0300
commit44fd5e0d3b755984a19d45122453c546988f5a4f (patch)
tree7047dfbad4cc6953a4b7c75c2a4db45f96a7fd6a /meta-ibm/meta-romulus
parent4360f15d680b7c5cd6f49902288e90cac69b18f3 (diff)
downloadopenbmc-44fd5e0d3b755984a19d45122453c546988f5a4f.tar.xz
meta-ibm: move all services to multi-user.target
Instead of obmc-standby.target, use multi-user.target. (From meta-ibm rev: 85cff8cc9e66049d8ac26271c13f82d894ac572f) Change-Id: I03c3d41c031343fa584511889c70e3def92cb83d Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-romulus')
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service
index 7452b9182..e72d33af9 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service
@@ -10,4 +10,4 @@ ExecStart=/usr/bin/env phosphor-cooling-type ${{OBJPATH}} ${{AIR}}
SyslogIdentifier=phosphor-cooling-type
[Install]
-RequiredBy={SYSTEMD_DEFAULT_TARGET}
+RequiredBy=multi-user.target
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 86ed1d4a2..e388748c3 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -9,7 +9,7 @@ PACKAGECONFIG += "cooling-type"
TMPL_COOLING = "phosphor-cooling-type@.service"
INSTFMT_COOLING = "phosphor-cooling-type@{0}.service"
-COOLING_TGT = "${SYSTEMD_DEFAULT_TARGET}"
+COOLING_TGT = "multi-user.target"
FMT_COOLING = "../${TMPL_COOLING}:${COOLING_TGT}.requires/${INSTFMT_COOLING}"
FILES_phosphor-cooling-type = "${sbindir}/phosphor-cooling-type"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb b/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
index 90513b4d1..cd2bab996 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
@@ -23,7 +23,7 @@ ID_BUTTON_SERVICE = "id_button"
TMPL = "phosphor-gpio-monitor@.service"
INSTFMT = "phosphor-gpio-monitor@{0}.service"
-TGT = "${SYSTEMD_DEFAULT_TARGET}"
+TGT = "multi-user.target"
FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
SYSTEMD_SERVICE_${PN} += "id-button-pressed.service"