summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-romulus
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-10 00:00:19 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-13 17:49:57 +0300
commitf5620611d1f6f6848ca7f3259368c3c3290ba643 (patch)
tree6af167c39753d4e9d25bbc52b93129b3a424a70e /meta-ibm/meta-romulus
parent40900b7ef1db429ab56966340d56721cdadd172e (diff)
downloadopenbmc-f5620611d1f6f6848ca7f3259368c3c3290ba643.tar.xz
meta-ibm: romulus: fix file search paths
Typically it does not make any sense to append to FILESEXTRAPATHS. FILESEXTRAPATHS is set in a bbappend when overriding something from another layer. The typical desire will be to make bitbake search for files in the layer with the bbappend and not some other layer earlier in the priority list. Further, appending to FILESEXTRAPATHS will introduce unexpected behavior when multiple layers append the same recipe - layers with higher layer priorities that append to FILESEXTRAPATHS will find their files overriden by files in layers with lower priorities. (From meta-ibm rev: e11f36155c0fc8a6cc4bb6ef5abee777b8ae6b5a) Change-Id: Idcd839211e009f260a38ae9cb6351154a8074c28 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-romulus')
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 072623eab..5c930a04d 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_append_romulus := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
# Package configuration
FAN_PACKAGES += " \
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index d3f84319e..378dab4d3 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_append_romulus := ":${THISDIR}/${PN}"
+FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
SRC_URI_append_romulus = " \
file://channel.yaml \
"