summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/conf
diff options
context:
space:
mode:
authorjmbills <42755197+jmbills@users.noreply.github.com>2019-10-25 19:18:16 +0300
committerGitHub <noreply@github.com>2019-10-25 19:18:16 +0300
commit0dbb60593ebb5a62190c0e6cff7f1770493303a2 (patch)
tree0df2ce67404dbca3ddc4ee063dbfd9ae455be682 /meta-ibm/meta-witherspoon/conf
parent34a3942845ac3264ce27c648ae5486d302c3e6d8 (diff)
parentcc9cea46d74d280de03c713c8b555153fd811f09 (diff)
downloadopenbmc-0dbb60593ebb5a62190c0e6cff7f1770493303a2.tar.xz
Merge branch 'intel' into intel2
Diffstat (limited to 'meta-ibm/meta-witherspoon/conf')
-rw-r--r--meta-ibm/meta-witherspoon/conf/conf-notes.txt14
-rw-r--r--meta-ibm/meta-witherspoon/conf/layer.conf2
-rw-r--r--meta-ibm/meta-witherspoon/conf/local.conf.sample1
-rw-r--r--meta-ibm/meta-witherspoon/conf/machine/mihawk.conf42
-rw-r--r--meta-ibm/meta-witherspoon/conf/machine/rainier.conf24
-rw-r--r--meta-ibm/meta-witherspoon/conf/machine/witherspoon-tacoma.conf25
-rw-r--r--meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf2
7 files changed, 106 insertions, 4 deletions
diff --git a/meta-ibm/meta-witherspoon/conf/conf-notes.txt b/meta-ibm/meta-witherspoon/conf/conf-notes.txt
index 9b3c01a55..0c78d458d 100644
--- a/meta-ibm/meta-witherspoon/conf/conf-notes.txt
+++ b/meta-ibm/meta-witherspoon/conf/conf-notes.txt
@@ -1,2 +1,12 @@
-Common targets are:
- obmc-phosphor-image
+Sample meta-witherspoon build invocations:
+
+mihawk:
+DISTRO=openbmc-witherspoon MACHINE=mihawk bitbake obmc-phosphor-image
+swift:
+DISTRO=openbmc-witherspoon MACHINE=swift bitbake obmc-phosphor-image
+witherspoon:
+DISTRO=openbmc-witherspoon MACHINE=witherspoon bitbake obmc-phosphor-image
+witherspoon-tacoma:
+DISTRO=openbmc-openpower MACHINE=witherspoon-tacoma bitbake aspeed-image-norootfs
+witherspoon-128:
+DISTRO=openbmc-witherspoon MACHINE=witherspoon-128 bitbake obmc-phosphor-image
diff --git a/meta-ibm/meta-witherspoon/conf/layer.conf b/meta-ibm/meta-witherspoon/conf/layer.conf
index 62b067874..8cac30c39 100644
--- a/meta-ibm/meta-witherspoon/conf/layer.conf
+++ b/meta-ibm/meta-witherspoon/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "witherspoon-layer"
BBFILE_PATTERN_witherspoon-layer := "^${LAYERDIR}/"
-LAYERSERIES_COMPAT_witherspoon-layer = "thud warrior"
+LAYERSERIES_COMPAT_witherspoon-layer = "warrior zeus"
diff --git a/meta-ibm/meta-witherspoon/conf/local.conf.sample b/meta-ibm/meta-witherspoon/conf/local.conf.sample
index 9dec7743d..d3a2303fc 100644
--- a/meta-ibm/meta-witherspoon/conf/local.conf.sample
+++ b/meta-ibm/meta-witherspoon/conf/local.conf.sample
@@ -1,3 +1,4 @@
+#MACHINE ?= "mihawk"
#MACHINE ?= "swift"
#MACHINE ?= "witherspoon-128"
MACHINE ??= "witherspoon"
diff --git a/meta-ibm/meta-witherspoon/conf/machine/mihawk.conf b/meta-ibm/meta-witherspoon/conf/machine/mihawk.conf
new file mode 100644
index 000000000..a296e79b0
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/conf/machine/mihawk.conf
@@ -0,0 +1,42 @@
+KMACHINE = "aspeed"
+KERNEL_DEVICETREE = "${KMACHINE}-bmc-opp-${MACHINE}.dtb"
+KERNEL_FEATURES_append = " phosphor-wdt-on-panic"
+
+UBOOT_MACHINE = "ast_g5_ncsi_config"
+
+OBMC_POWER_SUPPLY_INSTANCES = "0 1"
+
+PREFERRED_PROVIDER_virtual/p9-vcs-workaround = ''
+PREFERRED_PROVIDER_virtual/openpower-fru-vpd-layout = "mihawk-openpower-fru-vpd-layout-native"
+
+require conf/machine/include/ast2500.inc
+require conf/machine/include/obmc-bsp-common.inc
+require conf/machine/include/openpower.inc
+require conf/machine/include/p9.inc
+require conf/distro/include/phosphor-aspeednic-use-mac2.inc
+
+PHOSPHOR_MRW_LICENSE = "Apache-2.0"
+PHOSPHOR_MRW_LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+PHOSPHOR_MRW_URI = "git://github.com/open-power/mihawk-xml"
+PHOSPHOR_MRW_REV = "f6ec5aa0f9803d44b147a7670dec7ec935f59582"
+
+
+
+# Inhibit phosphor-hwmon-config-mrw
+VIRTUAL-RUNTIME_phosphor-hwmon-config_df-mrw = ""
+
+# Inhibit phosphor-fan-presence-mrw-native
+PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config_df-mrw = \
+ "phosphor-fan-presence-config"
+
+# Inhibit phosphor-fan-control-fan-config-mrw-native
+PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config_df-mrw = \
+ "phosphor-fan-control-fan-config"
+
+# Inhibit mihawk-led-manager-config-native
+PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native_df-mrw = \
+ "mihawk-led-manager-config-native"
+
+PREFERRED_PROVIDER_virtual/phosphor-logging-callouts_df-mrw = "mihawk-phosphor-logging-callouts-native"
+
+PREFERRED_PROVIDER_virtual/openpower-fru-inventory_df-mrw = "mihawk-openpower-fru-inventory-native"
diff --git a/meta-ibm/meta-witherspoon/conf/machine/rainier.conf b/meta-ibm/meta-witherspoon/conf/machine/rainier.conf
new file mode 100644
index 000000000..81d808a7b
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/conf/machine/rainier.conf
@@ -0,0 +1,24 @@
+KERNEL_DEVICETREE = "aspeed-bmc-ibm-rainier.dtb"
+UBOOT_MACHINE = "evb-ast2600_defconfig"
+
+MACHINEOVERRIDES =. "ibm-ac-server:witherspoon:"
+require conf/machine/include/ast2600.inc
+require conf/machine/include/obmc-bsp-common.inc
+require conf/machine/include/openpower.inc
+
+SERIAL_CONSOLES = "115200;ttyS4"
+
+MRW_XML = "witherspoon.xml"
+PHOSPHOR_MRW_LICENSE = "Apache-2.0"
+PHOSPHOR_MRW_LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+PHOSPHOR_MRW_URI = "git://github.com/open-power/witherspoon-xml"
+PHOSPHOR_MRW_REV = "c622cb5a5dd3ebc2a4eef558d1b70740f914e6f7"
+
+VIRTUAL-RUNTIME_phosphor-hwmon-config_df-mrw = ""
+
+PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config_df-mrw = \
+ "phosphor-fan-control-fan-config"
+PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config_df-mrw = \
+ "phosphor-fan-presence-config"
+
+FLASH_SIZE = "131072"
diff --git a/meta-ibm/meta-witherspoon/conf/machine/witherspoon-tacoma.conf b/meta-ibm/meta-witherspoon/conf/machine/witherspoon-tacoma.conf
new file mode 100644
index 000000000..e8a38300b
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/conf/machine/witherspoon-tacoma.conf
@@ -0,0 +1,25 @@
+KERNEL_DEVICETREE = "aspeed-bmc-opp-tacoma.dtb"
+UBOOT_MACHINE = "evb-ast2600_defconfig"
+
+MACHINEOVERRIDES =. "ibm-ac-server:witherspoon:"
+require conf/machine/include/ast2600.inc
+require conf/machine/include/obmc-bsp-common.inc
+require conf/machine/include/openpower.inc
+require conf/machine/include/p9.inc
+
+SERIAL_CONSOLES = "115200;ttyS4"
+
+MRW_XML = "witherspoon.xml"
+PHOSPHOR_MRW_LICENSE = "Apache-2.0"
+PHOSPHOR_MRW_LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+PHOSPHOR_MRW_URI = "git://github.com/open-power/witherspoon-xml"
+PHOSPHOR_MRW_REV = "c622cb5a5dd3ebc2a4eef558d1b70740f914e6f7"
+
+VIRTUAL-RUNTIME_phosphor-hwmon-config_df-mrw = ""
+
+PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config_df-mrw = \
+ "phosphor-fan-control-fan-config"
+PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config_df-mrw = \
+ "phosphor-fan-presence-config"
+
+FLASH_SIZE = "131072"
diff --git a/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf b/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
index 3f7aedcb9..20f515907 100644
--- a/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
+++ b/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
@@ -19,7 +19,7 @@ require conf/machine/include/p9.inc
PHOSPHOR_MRW_LICENSE = "Apache-2.0"
PHOSPHOR_MRW_LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
PHOSPHOR_MRW_URI = "git://github.com/open-power/witherspoon-xml"
-PHOSPHOR_MRW_REV = "e76c2fc5aeb512a0eb33438c239746de5b629885"
+PHOSPHOR_MRW_REV = "c622cb5a5dd3ebc2a4eef558d1b70740f914e6f7"
# Inhibit phosphor-hwmon-config-mrw
VIRTUAL-RUNTIME_phosphor-hwmon-config_df-mrw = ""